­čôŽ Nowe wersje pakiet├│w binarnych w repozytorium APT

:package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package:
:package: :package: :package: Nowe pakiety w repozytorium APT :package: :package:
:package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package: :package:

:warning: To og┼éoszenie dla tych, kt├│rzy sami w konsoli instaluj─ů pakiety binarne na bramce.
Oczywi┼Ťcie, nie trzeba instalowa─ç pakiet├│w r─Öcznie, wystarczy poczeka─ç na aktualizacj─Ö - wszystko zostanie wykonane automatycznie podczas kolejnej aktualizacji.

Niestety JFrog Bintray og┼éosi┼é zamkni─Öcie swoich repozytori├│w (b─Öd─ů dzia┼éa─ç jeszcze tylko kilka miesi─Öcy)

nie nacieszyli┼Ťmy si─Ö za d┼éugo darmowym hostingiem pakiet├│w, kt├│ry og┼éosili┼Ťmy tu:

Dlatego wr├│cili┼Ťmy do kompilowania i hostowania pakiet├│w binarnych na w┼éasnym serwerze:

https://powiedz.co/apt/

Oczywi┼Ťcie nie jeste┼Ťmy sami, dotkn─Ö┼éo to tysi─ůce projekt├│wÔÇŽ ale nie ma tego z┼éego, nauczyli┼Ťmy si─Ö kilku rzeczy. Dzi─Öki temu wprowadzili┼Ťmy podobne rozwi─ůzanie i usprawnili┼Ťmy proces automaycznego kompilowania paczek i ich publikowania w naszym testowym repozytorium :slight_smile:

Aktualizacja pakiet├│w binarnych zostanie wydana niebawem na BETA i na koniec miesi─ůca na kanale stabilnym. Gdyby kto┼Ť si─Ö ju┼╝ nie m├│g┼é doczeka─ç :wink: to wystarczy wpisa─ç 3 komendy w konsoli:

apt update
apt upgrade
apt reinstall python

PS
za┼éatali┼Ťmy prze┼éaczanie repozytori├│w podczas u┼╝ywania nak┼éadki na apt.
pkg powinno by─ç ju┼╝ ok, ale i tak oficjalnie u┼╝ywamy apt

1 polubienie

To co jest teraz w

/data/data/pl.sviete.dom/files/usr/etc/apt/sources.list

czyli

deb https://termux.org/packages/ stable main

nie działa. Co wpisać zamiast tego? Czy to jest ok?

# The main AI-Speaker repository:
deb [trusted=yes] https://powiedz.co/apt dom stable
deb [trusted=yes] https://powiedz.co/apt python 3.9

Tak, tak to powinno wygl─ůda─ç.

dok┼éadnie tak - to s─ů nasze ustawienia i tylko takie s─ů OK
jak kto┼Ť ma inne repozytorium to znaczy, ┼╝e co┼Ť sam przestawi┼é (┼Ťwiadomie b─ůdz nie) wpisuj─ůc co┼Ť w konsoli.
Wiemy, ┼╝e dochodzi┼éo do zmiany repozytorium po wpisaniu komendy pkgÔÇŽ ta komenda mog┼éa by─ç podpowiedana w konsol - to jest ju┼╝ poprawione w nowych binarkach.

Oczywi┼Ťie je┼╝eli kto┼Ť obs┼éuguje system zgodnie z instrukcj─ů (u┼╝ywa apt) to takie rzeczy si─Ö nie dziej─ů.

Dzi─Ökuj─Ö. No ja tam nic nie grzeba┼éem i firmowo po zakupie dev1 z g┼éo┼Ťnikiem mia┼éem te niedzia┼éaj─ůce wpisyÔÇŽ :slightly_smiling_face:

@jolka: zaktualizowałem ręcznie pakiety z APT, spowodowało to aktualizację komara (:slight_smile:) do
obraz
tylko problem taki ┼╝e nie mo┼╝na si─Ö z nim po┼é─ůczy─ç z zewn─ůtrz.
Sprawdziłem plik konfiguracyjny, wszystko jest tak samo (tzn nie ma żadnych zdefiniowanych zmiennych, wszystko zahashowane).
Taki stan rzeczy sprawia ┼╝e np zigbee dzia┼éa (bo ┼é─ůczy si─Ö lokalnie) ale integracja tasmota ju┼╝ nie (bo urz─ůdzenie ┼é─ůczy si─Ö spoza bramki). Innych rzeczy nie sprawdz─Ö bo MQTTExplorer te┼╝ si─Ö nie ┼é─ůczy
plx fix :slight_smile:
EDIT:
dobra, nie było tematu :slight_smile:

Brakuje dowi─ůzania pip do czego┼Ť (pip2, pip3.9):


Na starszej wersji jest osobna binarka:

czyta┼ée┼Ť opis powy┼╝ej?

Dziękuję. Nowe repo działa. W końcu poszło apt install mc - to pierwsze co zawsze instaluję w linuxach :crazy_face:

1 polubienie

Oczywi┼Ťcie nie zauwa┼╝y┼éem :cold_sweat:

1 polubienie

@Jolka - czy co┼Ť si─Ö zmieni┼éo w repozytoriach?

teraz s─ů b┼é─Ödy (Forbidden!) na adresie https://dl.bintray.com/grimler/game-packages-24/dists/games/InRelease po wywo┼éaniu apt update

Masz b┼é─Ödne repo, zobacz ­čôŽ Nowe wersje pakiet├│w binarnych w repozytorium APT - #4 przez jolka

To nie jest prawda. Mam w┼éa┼Ťnie dok┼éadnie te. Dzia┼éa┼éy jeszcze ze 2 tyg temu.

DEV 3:


DEV 1:

W obu jeszcze kieruje do pkg
obraz

obraz
czyli ÔÇťna ju┼╝ÔÇŁ mo┼╝na pozby─ç si─Ö tych 2ch plik├│w z usr/etc/apt/sources.list.d/
@jolka podpowiesz czy znalaz┼éy si─Ö tam przypadkiem czy tak ma by─ç, ┼╝eby┼Ťmy sobie wi─Ökszego kuku nie zrobili? Ja na Franku beta jestem (DEV2), u mnie dzia┼éaÔÇŽ

Czyli REPO JUŻ działa. Ok - dzięki.

Tak, alternatywne repozytoria doinstalowywał stary pkg (nakładka na apt).
To jest ju┼╝ poprawione pkg nie zmienia ju┼╝ repozytori├│w na alternatywne.
Czyli wystarczy usun─ů─ç te pliki, i zaktualizowa─ç binarki za pomoc─ů apt i b─Ödzie ju┼╝ OK.

┼╗eby nie zrobi─ç sobie problemu wystarczy:

  • nie instalowa─ç samemu pakiet├│w z konsoli, nie ma takiej potrzeby pakiety s─ů aktualizowane automatycznie podczas instalacji
  • jak ju┼╝ musimy instalowa─ç to u┼╝ywamy apt tak jak to jest w dokumentacji i w ka┼╝dym naszym przyk┼éadzie na forum
  • jak ju┼╝ musimy pkg bo tak podpowiedzia┼éo, to nic si─Ö nie stanie, bo poprawione pkg nie zmienia repozytori├│w

Repozytoria same nigdy si─Ö nie prze┼é─ůczy┼éy, wymaga┼éo to wpisania komendy pkg kt├│r─ů my nigdy nie wspierali┼Ťmy. Ka┼╝dy kto eksperymentuje wpisuj─ůc co┼Ť w konsoli, a potem nie wie co si─Ö sta┼éo, mo┼╝e zawsze w prosty spos├│b wr├│ci─ç do domy┼Ťlnych kod├│w i ustawie┼ä:

1 polubienie