Awaria zigbee2mqtt CC2531

Use pm2 show <id|name> to get more details about an app
2|ais | 2021-03-21 09:02:39 INFO (MainThread) [homeassistant.components.ais_usb] [stderr]
2|ais | [PM2][ERROR] Process zigbee not found
32|zigbee | Zigbee2MQTT:info 2021-03-21 09:02:53: Logging to console only’
32|zigbee | Zigbee2MQTT:info 2021-03-21 09:02:53: Starting Zigbee2MQTT version 1.17.1 (commit #99274c7)
32|zigbee | Zigbee2MQTT:info 2021-03-21 09:02:53: Starting zigbee-herdsman (0.13.59)
PM2 | Stopping app:zigbee id:32
32|zigbee | Zigbee2MQTT:error 2021-03-21 09:03:06: Failed to call ‘OnEvent’ ‘stop’ (TypeError: Cannot read property ‘getEntries’ of null
32|zigbee | at Function.loadFromDatabaseIfNecessary (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/zigbee-herdsman/dist/controller/model/device.js:216:55)
32|zigbee | at Function.all (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/zigbee-herdsman/dist/controller/model/device.js:236:16)
32|zigbee | at Controller.getDevices (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/zigbee-herdsman/dist/controller/controller.js:268:31)
32|zigbee | at Zigbee.getClients (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/zigbee.js:145:30)
32|zigbee | at OnEvent.stop (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/extension/onEvent.js:23:42)
32|zigbee | at Controller.callExtensionMethod (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/controller.js:382:44)
32|zigbee | at async Controller.stop (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/controller.js:190:9))
32|zigbee | Zigbee2MQTT:error 2021-03-21 09:03:06: Not connected to MQTT server!
32|zigbee | Zigbee2MQTT:error 2021-03-21 09:03:06: Cannot send message: topic: ‘zigbee2mqtt/bridge/state’, payload: 'offline
32|zigbee | Zigbee2MQTT:info 2021-03-21 09:03:06: Disconnecting from MQTT server
32|zigbee | You have triggered an unhandledRejection, you may have forgotten to catch a Promise rejection:
32|zigbee | TypeError: Cannot read property ‘end’ of undefined
32|zigbee | at MQTT.disconnect (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/mqtt.js:93:21)
32|zigbee | at processTicksAndRejections (internal/process/task_queues.js:97:5)
32|zigbee | at async Controller.stop (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/controller.js:194:9)
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | pid=12190 msg=failed to kill - retrying in 100ms
PM2 | Process with pid 12190 still alive after 1600ms, sending it SIGKILL now…
PM2 | App [zigbee] with id [32] and pid [12190], exited with code [0] via signal [SIGKILL]
PM2 | pid=12190 msg=process killed
2|ais | 2021-03-21 09:03:08 INFO (MainThread) [homeassistant.components.ais_usb] [stdout]
2|ais | [PM2] Applying action deleteProcessId on app [zigbee](ids: [ 32 ])
2|ais | [PM2] zigbee

Jaką masz wersję oprogramowania na bramce?

U mnie.

obraz

Wersje całkowicie różne więc to raczej nie problem mojej bety. robiłeś przed awarią jakieś zmiany? Dodawałeś coś nowego?

nic nie robilem ,ale tak z ciekawosci juz mam tak drugi raz .Po pierwszym razie samo sie naprawilo a tutaj na razie nic

@jszkiela Twój problem wygląda jak to:

Natomiast w logach od @domex nie widzę tego co w logach @jszkiela. Nie robiłeś może ostatnio jakichś update’ów pakietów apt?
Wpisz w konsoli i pokaż co Ci zwróciło polecenie:

mosquitto -h

Mój przypadek jest jednak bardziej skomplikowany.

Zatrzymuję zigbee

obraz

Ale ono za moment samo się uruchamia… Czemu?

Wypnij dongle’a zmień port zigbee na 25, wepnij dongle’a i wtedy daj znać czy dalej problem występuje.

Nadal to samo.

Wyjąlem dongla.
Zrobiłem wpis w

obraz

włożyłem dongla. Niestety nadal cykliczne restarty. zigbee za każdym razem dostaje nowe id.

Hm… próbowałeś może inny port USB?
Zbierz logi - @araczkowski w tamtym wątku dał instrukcje jak je zebrać.

Tak, objechałem wszystkie porty USB.

Ma ktoś w Warszawie (lub okolicach) wolne CC2531?

Może spróbuj sam…

W sumie mogę spróbować. Tylko nie mam maliny. Jedynie zakurzone Arduino Mega. Ciekawe czy tym pójdzie?

Odpaliłem stare Arduino. wszystko idzie prawidłowo ale nie mogę znaleźć objcopy.exe Może ktoś podrzucić gotowy CC2531ZNP-Prod.bin.? Ewentualnie skąd pobrać objcopy.exe?

i nadal nie mam stosownego rozwiazania n,usze zamuwic programator u chinczyka ylko nie wiem dla czego zaplacilem wiecej za dongla skoro w chinach mialem taniej , myslalem ze bedzie jakies wsparcie ale niestety nie ma zadnego odzewu na maila
Pozdrawiam LM

Jest w instrukcji link:

Z tego co pamiętam @Cino111 próbował z WIN ale nie wyszło z powodu braku bibliotek.
Ja jechałem od razu z Linuxem.

Już mam objcopy.exe ale wali błędami. Możesz mi udostępnić skonwertowanego bina?

Plik bin kompilowałem pod Wemos D1 mini - ale nie mam go już nawet w archiwum… :disappointed_relieved:
Nie korzystam obecnie z Z2M więc bardziej były to zajęcia edukacyjne. Koordynator CC2531 leży sobie w szufladzie w razie wygrania jakiejś aukcji z czymś pod Zigbee.