ESP32 LilyGO TTGO T-Camera OV2640_V1.6.2

Dokładnie tak - mamy w niej CAMERA, OLED, PIR, BUTTON i MIC, ale niestety tasmota mikrofonu na razie nie obsługuje.

Jeśli ktoś ma inną wersję to konieczne będzie przemapowanie pin’ów w szablonie - wszystkie wersje są opisane tu: https://github.com/lewisxhe/esp32-camera-series

Faktycznie ta kamera ESP ma potencjał :slight_smile:

Okazuje się, że na ESP32 można już korzystać z biblioteki TensorFlow Lite. Czyli można dodać małe modele ML i np. wykrywać ludzi z kamery na ESP32.

Jeszcze jakiś czas temu wszyscy myśleli, że TF na czymś takim jak ESP32 to jest nie możliwe! :wink:

Tu jest gotowy przykład dla Arduino

Myślę, że to już tylko kwestia czasu i PIR będzie tylko uruchamiał wykrywanie człowieka kamerą w AIS-Tasmota :slight_smile:

Powinmo być tak:
PIR -> ESP32 cam -> Bramka AIS dom

wykryto ruch -> wykryto człowieka -> powiadomienie / zdjęcie / rozpoznanie osoby

3 polubienia

@araczkowski , @Cezary.K , @Sebastian … Powiedzcie co się dzieje, że na wersji Tasmota 8.5.0 ten moduł mi działa, a ma wersji 9.2.0 już niestety nie. Próbowałem różnych opcji, a konsola wypluwa mi błąd inicjalizacji kamery

cam: init failed with error 0x20004

Mój moduł kamery leży w szufladzie. Ale z własnego doświadczenia z innymi modułami ESP32 wiem, że są problemy z binarkami od AIS. W tej kwestii @Sebastian może zabierze głos… Obecnie jak już to wgrywał oryginalne pliki z Tasmota i uzupełniam konfigurację MQTT sam.

Próbowałem różnych wersji Tasmota od AIS i orginalnych i nic. Działa mi tylko na wersji 8.5.0. Dziwne… Sam kompilowałem i jest ten sam efekt…

cam: init failed with error 0x20004

Sprawdź dokładnie jaką masz wersję i czy numeracja pinów jest identyczna - podany szablon dotyczy v1.6.2.
Po wgraniu 9.2.0 musisz ten szablon dodać i aktywować w konfiguracji (nie jest zapisany w firmware). W 8.5.0 ustawienia pinów były skompilowane na sztywno ponieważ nie dało się ich wprowadzić za pomocą szablonu - wycofaliśmy się z tego ponieważ szablon już działa prawidłowo i umożliwia konfigurowanie dowolnych wersji.

1 polubienie

@Sebastian
Mam wersję taką samą, a gdy wklejam szablon po restarcie nic się nie zmienia i szablonu brak.



@Maniek - Jak zasilasz płytkę?

Kontrolnie: ptaszek przy szablonie postawiony?
obraz

Problem w tym, że nie nadpisuje mi nowego szablonu poprzez wklej. Udało mi się pozmieniać mapowanie pinów edytując istniejący szablon ESP32-DevKit. Po zapisaniu szablonu i aktywowaniu moduł ożył… @Cezary.K z tym ptaszkiem żartowałeś? Ale dziękuję za wszelką pomoc.

2 polubienia

Zakupiłem taki sam moduł ale przyszedł w werski 1.7
Niestety zmieniły się piny :frowning:
Troche pograbałem i prawie udalo mi sie wszystko uruchmic.

Wgrywamy wszystko tak jak pisze Sebastian w pierwszym poście, konfiguracja Tasmota Template trochę inna:
{“NAME”:“TTGO_V05”,“GPIO”:[1,1,1,1,5090,5088,1,1,5056,5024,5089,5091,1,1,5092,5184,0,640,608,5093,0,5152,4928,5120,0,0,0,0,4992,160,32,1,5094,0,0,5095],“FLAG”:0,“BASE”:2}

Ustawienia w konsoli robimy takie jak Sebastian.

Wyświetlacz działa, PIR działa, przycisk tez.

Wszystko śmiga, poza kamerą:

Nie ma podglądu :frowning:

Sprawdziłem wszystko. Mam piny takie:

Powinno wszytko działać ale kamerka nie chce. :-((((((

Sprawdź szablon:

WCFlip ON
WCMirror ON
WCResolution 6
WCSaturation 0
WCBrightness -1
WCContrast 1

Już to robiłem, byłem na tej stronie github-a, piny raczej ok bo wczesniej pisałem program (nie tasmota), który streamuje obraz. Musiałem tam poustawiać piny ręcznie i wszystko działa.
Sprawdzę jeszcze raz w Tasmocie, może gdzieś się walnąłem.

na GPIO26 masz ustawione CAM_PWDN
a u lewisxhe jest
image
dla wersji 1.6.2 też nie ustawiałem tego
PS: CAM_DATA nie sprawdziłem - nie widać ustawionych wartości na Twoim zrzucie.
ale zasada jest taka: DVP Y2 = 5 to ustawiasz GIPO5 CAM_DATA = 1
czyli Y2 to jest CAM_DATA 1 ( przesunięcie o -1)
kolejno dla każdego Y2 do Y9 mamy CAM_DATA od 1 do 8

1 polubienie

Sorry, za bardzo zmniejszyłem :slight_smile: Teraz lepiej:


image

Piny danych Y2-Y9 tez raczej dobrze. Wylaczylem PWDN, wczesniej tego nie zmienialem bo to PowerDown mode dlatego zignorowałem to, niech się nie usupia :slight_smile:

Ale dalej nie działa.

Najgorsze, że na porcie szeregowyn nie ma zadnego komunikatu o będzie. Wszystko niby OK.
Jak wczesniej miałem błedy do pokazywało “Cam not recognized”

Odkopałem swoją płytkę i mam nadruk v1. 7 więc jak znajdę chwilę to spróbuję wgrać Tasmota od AIS i porównamy. Może przybliżymy się do diagnozy.

EDIT




@Belamy
Wgrałem pliki, wkleiłem Twój szablon i odhaczyłem aktywuj, następnie komendy konfiguracyjne.
Niestety obrazu brak i co dziwne nie mogłem wyłączyć tego szablonu.
Więc ponownie z terminala, tym razem na początek czyszczenie esptool.py erase_flash
i ponowne wgranie zestawu:

esptool.py --chip esp32 --port /dev/ttyUSB0 --baud 921600 --before default_reset --after hard_reset write_flash -z --flash_mode dout --flash_freq 40m --flash_size detect 0x1000 bootloader_dout_40m.bin 0x8000 partitions.bin 0xe000 boot_app0.bin 0x10000 tasmota32-ais-webcam-disp.bin

Tym razem konfigurację dla ESP wpisałem z palca dla każdego GPIO

Zastanawia mnie tylko dlaczego masz listę wszystkich GPIO a u mnie wygląda to inaczej, lista jest zawężona. :thinking:

Co jeszcze ważne, widać poniżej w logach błąd spowodowany brakiem odpowiedniego zasilania.
Dopiero po podłączeniu do zasilacza (po USB) kamerka przesłała obraz.

Chodzi o wybrany moduł ana gorze parametrów w polu Typ.
Ja mam ESP32-Cam (2) a Ty masz ESP32-DevKit (1).
W ESP32-Cam (2) jest więcej pinów do definiownia.

Ale niestety, ustawilem wszystko w module tak jak Ty, piny recznie. i dalej nie mam obrazu a jedynie działającą Tasmotę, czujkę PIR, wyswietlacz i przycisk :frowning:

Mam dokładnie taką samą płytkę jak Ty. Podłączyłem tez zewnetrzy zasilacz i mam coś takiego w logu:

00:00:00.009 UFS: FlashFS mounted with 48 kB free
00:00:00.022 CFG: Loaded from File, Licz 1703
00:00:00.028 I2C: SSD1306 znaleziono w 0x3c
00:00:00.094 Projekt ais-dom Tasmota-DoorBell Wersja 9.3.1(webcam)-1_0_5_RC6(2021-04-12T19:48:50)
00:00:00.803 WIF: Łączenie z AP1 … w trybie 11n jak dom_…
00:00:02.540 WIF: Połączony
00:00:02.795 HTP: Aktywny serwer Web dom_… z adresem IP 192.168…
18:01:14.075 CAM: Initialized
18:01:14.701 MQT: Próba połączenia…
18:01:14.794 MQT: Połączony
18:01:14.800 MQT: tele/dom_878BAC/LWT = Online (Zachowane)
18:01:14.802 MQT: cmnd/dom_878BAC/POWER =

Przy linii CAM: mam Initialized czyli raczej OK, ale obrazu nie ma.
Na ekranie mam
image

Sprawdzilem co powinny wyswietlic sie pod “Webcam stream” i obraz powinien byc z http://192.168.50.xxx:81/stream czyli na 81 porcie protokół http i stream
ale jak to wpisze z reki do przegladarki to mam “Ta witryna jest nieosiągalna” (ERR_CONNECTION_REFUSED)

Chyba wgram jeszcze raz od nowa.

Przypomniałem sobie o wpisie @ziom. Jak zwykle bardzo wartościowym…

Może WCStreem masz wyłączy.

P.S.
Sprawdź w VLC

No to już problem rozwiązany. Ale banał…
Wszystko działa bez problemu winowajcą był Comodo Firewall, standardowo blokował wyjścia na port 81 !!!
Wszystkie ustawienia były poprawne. :joy:

1 polubienie
1 polubienie