ESP32 CAM AiThinker - Oprogramowanie 9.2.0(ais-webcam)

ESP32 Cam AiThinker w Asystencie domowym

Cam AiThinker

to tania i malutka kamerka na ESP32

Wgrałem do kamery oprogramownie AIS-Tasmota 9.2.0

Konfiguracja parametrów

image

wybrałem w GPIO4 PWM dzięki temu w menu głównym urządzenia pojawił się suwak którym można ustawiać jasność diody LED na kamerze

Inne parametry

Na stronie z dokumentacją Tasmota znalazłem komendy które umożliwiają ustawienia parametrów kamery:

WCMirror ON
WCResolution 6
WCSaturation 0
WCBrightness -1
WCContrast 1

komendy z parametrami wpisujemy w konsoli

powiększyłem obraz komendą WCResolution i teraz już widzę jak kiełkują moje małe roślinki :slight_smile:

i wszystko pod kontrolą - wilgotność na chwilę spadła bo otwierałem kiełkownicę żeby włożyć kamerę do środka

Wszystkie komendy znalazłem w dokumentacji Tasmota na tej stronie, tam jest też instrukcja programowania:

4 polubienia

Nasiona z karmy dla papug :stuck_out_tongue:

Projekt ekstra.
Pytanie brzmi czy można podłączyć do takiego ESP32 na przykład ds18b20 i kontaktron ? :wink:
Jeżeli tak to zamawiam 5 sztuk :grinning_face_with_smiling_eyes:

karma dla rybek :wink:

no raczej :wink:

jeżeli w konfiguracji modułu wybierzesz
GPIOx -> DS18x20

i podłączysz DS18x20 jakoś tak
image

do GPIP w kamerze (gdzie masz też 3.3V i GND)

to chyba zadziała :wink:

ja mam SI7021 i jak podłącze do GPIO14i skonfiguruje tak:

to efekt mam taki

może zamów na początek jedną :wink:

1 polubienie

obraz

1 polubienie

A czy ktoś posiada drukarkę 3d.
Jak wyceniacie taki wydruk ?
Świetne do garażu gdy chcemy widzieć czy brama faktycznie się zamknęła itd :slightly_smiling_face:

Edit.
Udało namówić mi się znajomego na wydruk…
Cena po znajomości. Jak będę miał u siebie to zaprezentuje w całej okazałości.

Witam.
Mam problem.
Wszystko dodane moduł sie połączył konfiguracja zrobiona ale brak obrazu.
Zrobiłem próbe na kolejnym esp32 (kupiłem 3) i wciąż to samo.
Jest jakiś szablon konfiguracji który trzeba ustawić ?

A jaki plik wgrałeś?
Szablony są na stronie Tasmota:

1 polubienie

Zgodnie z instrukcją pliki z adresami te podstawowe oraz tasmota32-webcam.bin
Całość skonfigurowałem przez termite.
A po podłączeniu do sieci resztę przez przeglądarkę.

Wgrywalem ten szablon i bez zmian.

To też sprawdzałem.
Nawet kartę włożyłem ale też nic nie dało.

Ja bez powodzenia wgrywam przez esptool. Czy czyściliście wcześniej pamięć plikiem blanc?
Moduł po restarcie zapętla się i nie bardzo wiem z czym jest problem?

Brownout detector was triggered - za słabe zasilanie, esp się resetuje co chwilę

1 polubienie

@ziom i @Cezary.K możecie zerknąć czy macie identyczna płytkę?
Wgrałem tasmota brak obrazu.
Wgrałem przez Arduino ide brak obrazu.
Może to wersja kamery. Już sam nie wiem.
Już sam nie wiem co jest grane.

@Kraszewsky - mam identycznie wyglądającą płytkę. Walczę z tym zasilaniem. Podłączam ładowarkę USB 5V 1500mA pod pin 5V.


W/g schematu z TEJ strony. Zalecają podpięcie się pod pin 5V. Zmienię przewody od ładowarki 5V na grubsze (jak radziłem innym) i będzie kolejna próba.

Ja zasilam 5v ale obrazu z kamery brak.

Mam mały postęp ale brak rozgłaszanego AP :thinking:
Jak wyczyścić pamięć tego ESP32?

P.S.
W tym nieszczęsnym roku to chyba nie ma sensu. Zobaczę co przyniesie w kwestii flash-owania tego ESP nowy…

Esp32 nie rozgłasza ap.
Trzeba przez termite wpisać komendy z ssid i haslem.
Taki urok chyba tego softu że lubi robić problemy. :slightly_smiling_face:

Próbowałem przez monitor portu w Arduino ale bez efektu…