Utrata konfiguracji w urządzeniach z Tasmotą

Dziś przydarzył mi się bardzo dziwny przypadek. Wszystkie urządzenia z wgraną Tasmotą (7 szt. SP111, 1 szt. Shelly 2.5, 1 szt. RGBW Magic Home) straciły w nocy swoje konfiguracje. Rano były widoczne w bramce ale bez wczytanych szablonów. W nocy nie było zaniku prądu ani żadnego zdarzenia pogodowego. Ostatnio aktualizowałem urządzenia do Tasmoty AiS 9.4 ale to chyba nie ma związku ponieważ RGBW Magic Home mam nadal na AiS Tasmota 9.1. Spotkał się ktoś z was z takim przypadkiem co może być przyczyną?

Straciły konfigurację czego? Ustawień MQTT, WiFi?

Nie rozumiem tego zdania…

Jest niespotykanym aby 7 urządzeń (jak wynika z Twojego opisu) z zostało zresetowanych do ustawień początkowych. Jeśli stało się to w jednym czasie to przychodzi m na myśl tylko jedna ewentualność.
Opisałem swój przypadek:

W parametrach modułu zamiast wybranego szablonu był Sonoff basic.

Tak Cezary nie przesłyszałeś się NA WSZYSTKICH URZĄDZENIACH. Zanik prądu wykluczony, nawet krótka przerwa wyświetla usterkę w systemie alarmowym do czasu ręcznego skasowania.

1 polubienie

coś jest na rzeczy,
też nam się tak stało z 2 roletami… ale one nie miały jeszcze 9.4.0 tylko 9.3.0
wygląda na to, że to jest związane z aktualizacja AIS / HA a nie Tasmota, będziemy się temu przyglądać

Więc wstrzymuję się z aktualizacją. Dzięki za informację.

W jednym urządzeniu (RGBW Magic Home) cały czas mam Tasmotę 9.1 i ono też straciło konfigurację. Wygląda więc na to że problem występuje na różnych wersjach Tasmoty. Zazmaczam że do dnia dzisiejszego nigdy z tym urządzeniem problemów nie miałem.

A gdy się przywróci konfigurację to urządzenie już je trzyma czy ponownie ją traci? A Ty zaktualizowałeś bramkę do Franka?

Nam się to stało dzisiaj rano. Automatyzacja normalnie zawsze sama zamyka rolety i otwiera a dzisiaj roleta stała się nie roletą i nie zadziałała.

W Tasmota jest coś takiego jak FALLBACK_MODULE temu się będziemy przyglądali

Select default module on fast reboot where USER_MODULE is user template

Może urządzenie nie mogło nawiązać połączenia z MQTT na bramce (bo była aktualizacja) i się zresetowało do FALLBACK_MODULE

https://tasmota.github.io/docs/Device-Recovery/

To za jakiś czas zostanie zrozumiane

Mi też się to stało rano. Jak się obudziłem żadne urządzenie z Tasmotą nie działało. Wystarczyło w każdym urządzeniu wybrać odpowiednią konfigurację z listy zapisać i wszystko wróciło do normy. Z żadnego modułu nic się nie skasowało jest wifi. mqtt, szblony.

Oprogramowanie na bramce mam Franka ale beta. Zainstalowana przynajmniej tydzień temu. Nie miałem z tą wersją żadnych problemów.

jolka tobie się roleta nie otworzyła a mi lodówka zaczęła płynąć :rofl:
Zmartwiłaś mnie tym że na bramce coś się może samo aktualizować. Myślałem że ona działa trochę inaczej niż Windows 10. :wink:

1 polubienie

Mi też to się stało wczoraj (ok. 02:00 lub 03:00 nad ranem - nie mam już logów) ale tylko na kontrolerze H801 z Tasmota-AIS 9.3.1. Zmienił się tylko typ urządzenia w “Parametry modułu”. Po zmianie na właściwy wszystkie dane miałem zachowane. Musiałem tylko wybrać właściwe akcje w automatyzacjach dla tego modułu bo ich nie było. Pozostałe urządzenia z tą wersją Tasmoty działały i działają bez problemu. Oprogramowanie to stabilna Ewa. Zauważyłem też że dwie automatyzacje, które ręcznie tworzyłem gdzieś mi zniknęły.

Czy nie zależy to od Franka?

Ja mm wersje 2021.2.4 (Darek) oraz około 20 urządzeń na AIS Tasmota wersja 7.1.2, 8.2.0, 8.3.1 oraz 8.5.0 i nie mam problemów o których piszecie.

Chyba to mamy, to się nazywa module2 i doszło w tasmota 11 miesięcy temu

Autorowi tej zmiany chodziło o to, że w przypadku gdy urządzenie się restartuje (z jakiegoś powodu) ileś razy pod rząd (bo sieć, bo prąd, bo czegoś nie może…) to Tasmota próbuje ratować sytuacje i zmienia konfigurację urządzenia właśnie na tą zdefiniowaną w module2

W ten sposób w przypadku wyjątków powodujących restart urządzenia, z bramy garażowej robi się gniazdko :wink:

W naszym przypadku nie ma problemu większego bo sprzedajemy tylko gniazdka z module2 ustawione na gniazdko a nawet jak się przełączą na Basic to i tak wszystko jest OK.

Gorzej jak się to komuś zadzieje z bramą garażową czy roletą - tak jak nam.

Te zabezpieczenia w Tasmota zawsze mają jakiś efekt uboczny, kiedyś ktoś wymyślił, że po kilkukrotnym zaniku prądu urządzenie powinno wykasować parametry. Okazało się, że na polach namiotowych zaniki prądu to normalna rzecz i właściciel pola ma setki urządzeń do konfigurowania. Było też tak, że po kilkukrotnym (chyba 7 razy) szybkim włączeniu i wyłączeniu urządzenie się restartowało do ustawień fabrycznych, my to zablokowaliśmy po reklamacji klienta którego dzieci bawiły się dotykowymi przełącznikami :wink:

Chyba to przełączanie modułu też zablokujemy, bo jakoś nie bardzo rozumiemy jak to by mogło komuś pomóc???

Zgłaszamy dalej, do największego mózgobuwa @admin.ai-speaker

2 polubienia

To chyba prawda co piszesz. Nie wiedziałem, że coś takiego jak reset modułu jest w Tasmota, trudno za tym wszystkim nadążyć.

Najprościej zablokować w nowej kompilacji Tasmota, ale na spokojnie zobaczę jeszcze czy to nie jest gdzieś potrzebne, żeby czegoś innego nie popsuć.

PS
Tasmota ostrzega

Dlatego ja przestałem ogłaszać info o nowych wersjach Tasmota, bo od miesięcy urządzenia działają OK i nie ma w nich nic takiego, co potrzebuje aktualizacji. SUPLA nie aktualizuje chyba nigdy i działa.

Postawa godna naśladowania :slight_smile:
Ja też nie rozumiem poco ten pośpiech z tymi wersjami… i jestem zwykle 1 do tyłu.

Pozytywne jest to, że to przełączanie modułów jest specjalnie dodane w kodzie Tasmota / AIS-Tasmota i nie ma związku z Frankiem, chyba to się jakoś zbiegło w czasie… albo czegoś jeszcze nie rozumiem. Popatrzę na to na spokojnie dzisiaj i jutro. Jak coś znajdę to dam znać.