Wled esp 32 i pasek ws2815

Witam, mam taki problem zainstalowany wled na esp32 i zasilacz 12v 12 amper podlaczony pasek 6m ws2815 na 12v, zasilanie podpiete z tylu i z przodu, chodzi mi o efekt przyciemnienia i rozjasniania stopniowego swiatla bialego, problem mam taki ze po calkowitym sciemnieniu led swieca mi sie niektore kolory na niektorych ledach czerwony niebieski, i podczas wlaczania presetow przebijaja te kolory tak jakby jakis inny preset byl odpalony. Co moze byc nie tak w ustawieniach zmienilem opcje napiecia i ilosci led na 329 sztu. Prosze o pomoc

Nie napisałeś nic jak masz wykonane sterowanie na liniach danych. Tu najłatwiej o błąd w podawaniu sygnałów i sprzętowe niedopasowanie ich poziomów.

Czy przejrzałeś dokumentację?

https://kno.wled.ge/basics/top5_mistakes/

Ja bym raczej stawiał na włączoną nakładkę zegara analogowego (to akurat łatwo zdiagnozować, bo krótkoterminowo to są te same LEDy, a długoterminowo inne) albo jakiś inny efekt, który może pracować w tle.

Nie da się wykluczyć wadliwych układów (jeśli zawsze to te same LEDy tj. piksele), ale by się przekonać gdzie leży problem wystarczy włączyć offset pierwszego piksela - jeśli te nieprawidłowo pracujące się przesuną właśnie o offset to układy WS2815 są sprawne, a problem leży w konfiguracji WLED, jeśli pozostaną nadal wadliwie pracujące te same to prawdopodobnie są uszkodzone, więc lutownica do ręki i wycinamy wadliwe segmenty.

Podstawilem drugi sterownik wgralem inny soft, efekt jest ten sam, (nakladka zegara amalogowego co to jest i jak to wylaczyc

śr., 15 maj 2024, 15:13 użytkownik szopen z AI-Speaker <notifications@ai-speaker.discoursemail.com> napisał:

To efekt, sam nie powinien się włączyć, jedyna możliwość, to wadliwa konfiguracja, którą sam robiłeś.

Czym jest nakładka
https://kno.wled.ge/features/segments/#effect-overlay
zegar sam sobie musisz poszukać po dokumentacji (jeśli jest w obecnej jej wersji)

Czy te piksele zachowują się jak zegar ? (wybrane piksele przeskakują co godzinę, minutę i sekundę).
Czy są po prostu wadliwe?

Oznacz które to piksele, rozlutuj taśmę w połowie i podłącz drugą połowę (zamiast pierwszej), sprawdź czy nadal są te same wadliwe piksele.

Naprawdę nie możesz szczegółowo opisać objawów??
Szklane kule nam słabo działają.


A i z tego wszystkiego zapomniałem spytać co się dzieje jak zdefiniujesz offset (od którego piksela ma być wyświetlane cokolwiek), to eliminuje konieczność lutowania - jeśli wady się przesuną o offset to problem leży w konfiguracji, a nie wadliwych modułach RGB.