Gniazdko GOSUND SP111

W końcu udało mi się zaprogramować gniazdo. Natomiast bramka nie widzi tego urządzenia. Po wejściu przez IM urządzenia wyświetla mi ile aktualnie kw pobiera dane urządzenie, jakie jest napięcie itp. Ale nie mogę tego sparować z bramką pomimo że mam identycznie ustawioną zakładkę MQTT (tzn. adres IP i hasło oraz użytkownik) dla innego przekaźnik, który jest widoczny na bramce.

Morze zwyczajnie MQTT nie włączyłeś:

ok, już śmiga. Potrzebny był restart bramki i jest już widoczne gniazdko :slight_smile:

@Riczard jak rozwiązałeś problem z połączeniem się do sieci vtrust-flash?

Próbowałem aż do skutku. Na początku sieć pojawiałą się dosłownie na kilkadziesiąt sekund i zanikała. telefon próbowałsię z siecią połączyć ale ostatecznie był komunikat że jest nie połączony. Potem po którejś próbie pojawiłą sie i odrazu podłączyłęm się do niej potem była już widoczna do końca procesu flashowania.
Jeśłi masz jakąś sieć wifi zapisaną , z którą telefon łączy się automatycznie to polecam kliknąć “zapomnij sieć” wtedy. U mnie jak tego nie zrobiłem to przy nieudanej próbie podłączenia do sieci vtrust-flash łączył z zapamietaną siecią.

Mam z koleji pytanie czy lepiej to gniazdko zintegrować z MQTT czy z Tasmotą na bramce ? Mam też problem z wykresami do gniazdka. Nie pokazuje wykresów.

Nie wiem nic o integracji Tasmota, bo od początku używam MQTT.
Jak mantrę powtorzę, dwie komendy do wpisania w Tasmota jeśli inne binarki niż od AIS.
Setoption19 1
GroupTopic dom

1 polubienie

Dochodzę do wprawy…
vlc-record-2021-02-17-20h54m22s-cinnamon-20210217-11.webm-.mkv (1,9 MB)

@Cezary.K potrzebuję Twojej pomocy.

Wgrałem Tsmotę poprzez tuya-convert (za pomocą RPi); gniazdko rozgłasza sieć 192.168.4.1 - mogę się połączyć i widzę oryginalną Tasmotę

Piszesz - “wgrywasz przez OTA plik minimal od AIS. Po restarcie wgrywasz Tasmota PL.”

Pomóż mi w tym właśnie kroku - co mam zrobić?

Dzięki

Jak widzisz Tasmotę to przechodzisz na zakładkę “Aktualizacja oprogramowania”

Następnie wybierasz plik, zatwierdzasz i aktualizujesz. I tak dwa razy najpierw minimal a następnie docelowe oprogramowanie.

dziękuję - dokładnie, który pliki od AIS mam wgrać. proszę o ścieżki, będę wdzięczny :slight_smile:

Oj leniuszek.

tasmota-minimal.bin

tasmota.bin

dziękuję. nie byłem pewny co do tego drugiego - przepraszam za kłopot

nie ma problemu czytaj dokumentację.

Przez OTA niestety nie idzie ale poprzez pobranie zapisanych wcześniej plików - tak, jest ok.

Wszystko software’owa działa, menu AIS Tasmota PL jest ale gniazdo reaguje przy włącz/wyłącz tylko zapaleniem się lub zgaśnięciem diody; przekaźnik nie działa. Rozumiem, że muszę wybrać typ gniazda? Może wiesz jak to jest przy SmartDGM (biodronkowe)?

EDIT - mam chyba:

{“NAME”:“SmartDGM Plug”,“GPIO”:[0,0,0,17,134,132,0,0,131,52,21,0,0],“FLAG”:0,“BASE”:18}

@sdsi Szkoda, że nie odczytałem Twojego wpisu wcześniej… Czy po wgraniut Tasmota przez Touya Convert wykonałeś polecenie reset2 1?
Jeśli nie, to możesz mieć małe ptoblemy z tym gniazdkiem. Opisywaliśmy w tym temacie nasze doświadczenia z dziwnym zachowaniem gniazdek po zaktualizowaniu do Tasmota od AIS.

Nie - nie robiłem reset1. Co to daje? Na razie chyba działa po ustawieniu tego szablonu.

Mogę jeszcze raz przeflashowac - napisz co daje to polecenie i jakich ew problemó się spodziewac?

p.s. mam 280V na mierniku tego gniazdka

Przepraszam, powinno być reset2 1
Przeczytaj cały temat.

Gniazdka świrował i potrafiły po zaniku napięcia gubić ustawienia WiFi nie dając ich zmienić i rozgłaszając dwie sieci Ssid jednocześnie, pozostawało otwieranie i flash po kablach.

Odczyty są dziwne, bo czeka Cię jeszcze kalibracja

Dobrze - więć co teraz mogę zrobić? Ponowny reflasch na Tasmotę?

Zrobiłem taż flash na żarówce DGM - działa.

SmartDGM L-WT9W1 9W 800lm CCT Bulb
{“NAME”:“L-WT9W1”,“GPIO”:[0,0,0,0,0,37,0,0,9,38,0,0,0],“FLAG”:0,“BASE”:18}