Home Assistant Supervised Dev3 - Ethernet 100 Mbps

nie mam 32 mam 64

No OK, jednak 64GB (podobnie jak 128GB) to już musi być sdxc, natomiast do 32GB są sdhc, być może to jest przyczyna Waszych problemów.

Nie dałem rady ściągnąć obrazu na wasze bramki (na LTE pliki tych rozmiarów pobieram na nocnym pakiecie, bo dzień mi szkoda transferu), a odpuściłem z powodów wspomnianych wyżej, Mega też się coś pluje że na darmowym koncie może braknąć transferu, więc faktycznie coś nie halo (na prostą logikę nie jest prawdopodobna taka różnica po uzupełnieniu systemu o jeden sterownik, tam muszą być jeszcze jakieś zbędne dane jak na obraz instalacyjny).

PS doczytałem, że @sdsi jednak się udało, więc skreślam.
W przypadku kart A2 mogą być problemy innego rodzaju.

@zielony
Podsumowując tesowałęś 2 karty - 64GB i 128GB?

spakowany obraz ma koło 7GB, wejdzie albo i nie wejdzie, zależy co zawiera

tak 2 oby dwie na fotkach są

Spoko, próbowałeś je sprawdzić?
Tak jak sugerowałem lub w inny skuteczny sposób (w 2 uszkodzone karty nie wierzę, ale sprawdzić zawsze warto).

Pokopałem po internecie i wygląda na to, że u-boot akurat w tym modelu tv-boxa nie wspiera niektórych trybów transferu stosowanych w kartach SD (a właściwie w rozszerzeniach podstawowego standardu SD).

Mam też wstępną odpowiedź na pytanie - dlaczego archiwum ais_dev3_100_bookworm_6.1.55_server_2023.10.03.img.gz jest takie duże (Mega faktycznie ma ograniczenie transferu do 5GB w 6 godzinnych okienkach, więc pobranie tego pliku było ultra-upierdliwe), otóż zawiera ono obraz nośnika o wielkości 16GB.
Nie wiem dlaczego “niemal pusty” obraz tak źle się kompresuje, spróbuję go skompresować bardziej (na moim laptopie to zajmie kilka godzin) i jeśli ktoś będzie potrzebował to udostępnię (o ile wyjdzie mniejszy od 5GB).
Więc z pewnością istnieją karty 16GB, na których się on zmieści, niestety nie ma gwarancji, że zmieści się na każdej karcie 16GB, a to z tak banalnej przyczyny, że karty oznaczone jako taka sama pojemność potrafią się minimalnie różnić rozmiarem w zależności od użytych podzespołów, natomiast gwarantuję, że śmiało można użyć karty 32GB lub 16GB (ale najlepiej identyczne z tymi sugerowanymi przez AIS - to daje szansę, że 16GB będzie identyczne z użytą kartą w R&D AIS).

Natomiast mam odpowiedź na niezadane pytanie - jakim cudem inne archiwa są mniejsze?
(żal mi transferu na pozostałe pliki, więc sprawdziłem tylko ais_pro1_lunar_6.1.46_server_2023.08.27.img.gz)
Tam w środku jest skompresowany obraz nośnika o rozmiarze 8GB (i pewnie tak samo jest w pozostałych przypadkach)

1 polubienie

Gdzieś widziałem wątek na forum Armbian o tym więc coś jest na rzeczy.

Pytanie - dlaczego na mojej bramce to ruszyło? Może @jolka coś mi dograła do bramki co rusza akurat mój egzemplarz?

Z drugiej strony przecież bootowalo mam bramkę wcześniej z karty SD tylko bez prawidłowej obsługi karty sieciowej? :slight_smile:

Nie znam waszego sprzętu, ale na większości platform można aktualizować u-boot.

To teraz nie bootuje z karty? To jak w końcu jest?
Z tej samej karty tv-box nie bootował, a teraz bootuje, czy o co chodzi?

Gdybyście mogli się zamienić kartami, to by można było to potwierdzić/zaprzeczyć, to w sumie fatalnie, że serwis nie informuje co robił ze sprzętem…

Ok. Może ja jestem nieprecyzyjny.

U mnie bootuje i działa (moje dev3 było u nich). U kolegów ten sam model dev3 i nie działa.

@sdsi
nic z Twoją bramką nikt nie robił, powstrzmajcie się proszę przed kolejnymi teoriami spiskowymi, bo to niczemu nie służy :wink:

zdjęcia od @zielony wskazują na problem z kartą (obraz jest ten sam i u @sdsi przecież działa)

co do wcześniejszych pytań o rozmiar obrazu - w skrócie: jest teraz większy, przy kolejnej wersji postaramy się to zmienić. Tu też proszę nie doszukiwać się na siłę drugiego dna :slight_smile:
Tu jest kod, którego używamy do tworzenia obrazu i jego zmniejszania. Następnym razem sprawdzimy, czemu się nie zmniejszył

1 polubienie

Jak mogłaś zrozumieć, że to jakiś zarzut? Niebywałe… :face_with_hand_over_mouth: Dziękuję za pomoc, nie wiem co pomogło bo się na tym nie znam; dyskutuje z troską z kolegami bo chce by im też działało a Ty zarzucasz jakieś teorie spiskowe wobec kawałka sprzętu? To trochę przykre jest i nie przystoi… Weź proszę oddech i cofnij się krok przed tą wypowiedzią.

Jeśli moja wypowiedź wcześniej była nieprecyzyjna i Cię uraziła to przepraszam.

Bez urazy oczywiście.

Pozdrowienia😎 eot

@Celina

To nie jest teoria spiskowa, takie wstawki o spiskach wkurzają chyba wszystkich waszych klientów (nie ukrywam mnie zagotowaliście już 2-krotnie mimo, że bramki AIS nie kupowałem, jakkolwiek inny sprzęt tak i to 2x, i w obu przypadkach były problemy z którymi sobie poradziłem samodzielnie, ale jak widać nie każdy użytkownik sprzętu, który przeszedł przez Wasze ręce jest równie samodzielny), gdybyście byli bardziej transparentni, a mniej marketingowi, to pewnie by to zadziałało pozytywnie w obie strony.

  1. sprawdziłem rozmiar systemów plików w obu przeanalizowanych obrazach - wniosek: 15GB z groszami jest niepotrzebne, wystarczy spokojnie koło 6GB (a może i mniej? skoro dajecie radę wyprodukować inne obrazy na bazie mniejszego systemu plików to i ten się powinien dać tak zmniejszyć - problemem jest konkretnie rozmiar obrazu partycji ext znajdujący się w obrazie nośnika)
    edit: sprawdziłem też pozostałe obrazy dla innych modeli bramek, co potwierdza tylko to co pisałem przed tą edycją - pozostałe obrazy są też przygotowane z partycją ext o rozmiarze rzędu 6GB

  2. kompresja gzip pachnie XIX wiekiem (poświęciłem cały dzień na skompresowanie obrazu podwyższając stopień kompresji gzip do maksymalnego i uzyskałem pseudo-poprawę - zmniejszenie wielkości archiwum zaledwie o jakieś 150MB), kompresja xz jest na współczesnym sprzęcie o wiele bardziej efektywna i szybsza (archiwum mi wyszło wielkości 5,7GB), nie zmienia to faktu że nie sposób zejść poniżej 5GB (czyli limitu transferu darmowego użytkownika Mega), to może załatwić jedynie mniejszy rozmiar źródłowego systemu plików (co chyba jesteście w stanie osiągnąć szybko i łatwo, skoro inne obrazy tak przygotowaliście).

A po przejrzeniu tych kroków przygotowawczych, to moim zdaniem ktoś zapomniał o kroku piątym, więc chyba czas na posypanie głowy popiołem.

1 polubienie

kupiłem dzisiaj nową kartę scandisk 64 A1 no i poszło nie wiem dlaczego na tamtych kartach nie działało bo chodzą w kamerach teraz !!! i jest wszystko ok ale dziękuję za sugestię

1 polubienie

No i super.

A ekranik dalej nie działa?

no nie no i te 20 znaków

@sdsi a co Ty tak tego ekraniku żałujesz? :wink: Nie masz innych zegarków w domu? :laughing:

Ale jak koniecznie chcesz to można:

LED Screen Display Control Instructions

Może któraś konfiguracja zadziała, jest też DIY:

1 polubienie

Znam tą tabelkę. Ale ta nasza kochana brameczka dev3 w tej pierwszej wersji (100Mbps) nie łyka tych ustawień. Są w sieci inne - całą masa - i weź tu utraf w trybie 99. Ale mam postęp - udało mi się ożywiść ten ekranik ale na razie czasu dobrze nie pokazuje a to co pokazuje to do góry nogami…:slight_smile: @zielony - pokombinuję i dam znać.

3 polubienia

UPDATE- mam plik od ekraniku, odwróciłem zegar i jest we właściwej proporcji. ALE - nie mogę dojść do ładu z kolejnością wyświetlania liczb z zegara:

Cytat
If the order of the displayed time text is incorrect, you can adjust the order of numbers in vfd_chars='4,0,1,2,3' to vfd_chars='1,2,3,4,0'

Jedno i drugie wyświetla jak chce…Ktoś pomoże? Albo rozszyfruje co za co odpowiada?

Podejrzewam, że chodzi o 1, 2, 3, 4 i 5 cyfrę (lub inny znak), ale że nie mam sprzętu to tylko zgaduję (jakkolwiek wyświetlacze VFD mają zwykle multipleksowany każdy znak osobno).

Czyli konkretnie jak?

1 polubienie

kombinacje cyfr 1,2,3,4,0 (także pominięcie niektórych i zastąpienie innymi) robią takie rzeczy - zegarek miesza liczby, nie wyświetla niektórych, wyświetla w odwrotnej kolejności, czasami pojawia się dwukropek a czasami migająca kropka - w różnych miejscach wyświetlacza; do tego ikonki znikają lub się pojawiają i to w trakcie pracy (jakby były częścią zegarka) :slight_smile:

Znalazłem kombinację - 4,0,1,2,3 - wyświetla się poprawnie czas z migającym dwukropkiem. Za to zniknęły wszystkie ikonki :slight_smile:

W zasadzie może tak zostać. Ale w sumie to ciekawe rozszyfrować ten kod - może pomożesz? :slight_smile:

Cyfra 5 w tym schemacie nie występuje.

@zielony - dałem opis - Dev3 (100 Mbps) i wyświetlacz VFD - #2 przez sdsi

1 polubienie

Cyfra 5 nie występuje, bo w sterowniku wyświetlacza masz 5 fizycznych segmentów o logicznych numerach od 0 do 4.

Zrobiłeś na nich taki test zapisu, jaki sugerowałem, czy olałeś temat?
(radzę zrobić, to jest w twoim interesie)

masz racje zrobię te testy i dam znać
Warning: Only 120548 of 120549 MByte tested.
Test finished without errors.
You can now delete the test files *.h2w or verify them again.
Writing speed: 28.6 MByte/s
Reading speed: 29.9 MByte/s
H2testw v1.4