Sonoff RF Bridge oraz soft AI Speaker

Jak wgrywasz kablem to mozesz od razu wgrać docelowy. Tak jak pisalem wyzej - GPIO0 zwierasz do masy na 5s i bedzie rozglaszal sieć.

Tam chyba jest przełącznik on/off i za jego pomocą wchodzi się w tryb flash i rozglaszanie sieci.

  1. Wg internetu przycisk on/off odpowiada za modul RF nie za WiFi. Zreszta, probowalem go przelaczac, bez zmian.
  2. Myslalem ze zwarcie GPIO z GND jest wymagane dla softu AI-Speaker a nie Minimal (jako ze w oryginalnym sofcie Tasmota WiFi dziala bez problemu)
  3. Po kablu nie moge wgrac - Termite ani zadna inna aplikacja do polaczenia sie po serialu nie jest w stanie polaczyc sie z moja bramka po wgraniu softu Minimal
  4. Mam wersje R2 (schemat jest tutaj: https://www.itead.cc/wiki/images/a/ad/Sonoff-RF_Bridge_hardware_1.PNG). Moze jestem slepy ale gdzie jest gniazdo GPIO0? Szukalem na schemacie, nie moge znalezc. Szukalem na plytce - tez brak. Googlalem w necie - jedyne schematy z GPIO ktore znalazlem, tyczyly sie wersji R1. Na stronie Tasmota tez nic nie pisza na temat GPIO0.

Poleglem, nie wiem co moglbym wiecej zrobic :frowning:

Już jest napisane w jaki sposób aktualizować soft AISpeaker :wink:

Dzieki :slight_smile: Jesli moge, kilka uwag to tego FAQ

  1. Jesli ma byc to FAQ dla konkretnie zielonych osob, warto napisac jak przefleszowac softem minimal gotowe urzadzenie np firmy Sonoff (tzn ze trzeba podpiac przejsciowke UART-USB etc). Wg instrukcji Tasmota soft Minimal nie moze byc pierwszym zainstalowanym na plytce

The Minimal version allows intermediate OTA uploads to support larger versions and does NOT change any persistent parameter. This version should NOT be used for initial installation

  1. Warto podac link do softu Minimal (wiem, czepiam sie ale FAQ to FAQ)

  2. W zadnej instrukcji nie ma informacji o koniecznosci zetkniecia GPIO0 z GND ani nie ma informacji jak znalezc pin GPIO0. Wiec ja wciaz nie wiem jak go znalezc :frowning:

Ad1 nie doczytałeś dobrze FAQ bo taki temat jest:


Ad2 przecież w temacie jest link do softu
Ad3 jak w punkcie 3, przykład jest zrobiony dla konkretnego modułu, jak ktoś potrzebuje informacje dla innych to pytać

No wiec gdzie moge znalezc GPIO0 na plytce Sonoff RF Bridge R2. Czy jest to ten przycisk, ktory wciskam aby flaszowac plytke?
Jesli tak, to nie pomaga, trzymam go przez 5sek i WiFi sie nie pojawia w wersji minimal :frowning:

Dobra, udalo mi sie zainstalowac soft AI-Speaker:)
Oto co zrobilem:

  1. Sflaszowalem plytke softem Minimal, ale uwaga - wlacznik RF mialem w pozycji ON a nie OFF
  2. Probowalem ustawic SSID sieci, zarowno poprzez konsole jak i poprzez uaktywnienie WiFi (GPIO0 jest jednak tym przyciskiem z lewej strony)
  • o dziwo, Termite widzial modul ale proba skonfigurowaina sieci WiFi za kazdym razem konczyla sie niepodzeniem - wydaje mi sie ze w konsoli mignal sie nawet komunikat w stylu “uwaga, brak mozliwosci zapisania konfiguracji”
  • pojawiala sie domyslna siec WiFi (o nazwie asmota3) ale proba podpiecia sie do niej i otworzenia 192.168.4.1 skutkowala bledem “nie mozna nawiazac polaczenia ze strona” - testwane zarowno na laptopie jak i na komorce
  1. Majac wersje Minimal na plytce, zainstalowalem soft AI-Speaker (wciaz majac przelacznik RF w pozycji ON)
  2. Zresetowalem plytke, po odpaleniu przytzrymalem przycisk GPIO0 przez kilka sekund i… pojawila sie dostepna sieci dom_…
  3. Podpialem sie pod ta siec, pojawil sie panel konfiguracyjny, wpisalem dane mojej sieci domowej

I dziala :slight_smile:

Wiem ze moj opis wyglada troche dziwnie (zwlaszcza w kontekscie tego wlacznika RF) ale zadzialalo.

Dzieki wielkie za wsparcie

Dobra, ciag dalszy problemow z bramka Sonoff RF Bridge :slight_smile:
Mam juz soft AI-Speaker, dodalem bramke wg instrukcji, bramka jest widoczna na liscie urzadzen AIS. I teraz probuje ja nauczyc kodow:

  1. Kilka Start nasluchiwania, bramka mowi “Bramka RF w trybie nasluchiwania”
  2. Ruszam czujnikiem - kod zostaj rozpoznany
  3. Klikam jeszcze raz “start nasluchiwania” (nic innego nie moge zrobic, nie pojawia sie pole aby nazwac czujnik, tudziez go dodac)
  4. Slysze komunikat “Bramka RF w trybie transmisji”. Dopiero teraz pojawia sie pole do podania nazwy dla znalezionego kodu oraz dopiero teraz pojawiaja sie przyciski Testuj, Dodaj przycisk, Dodaj czujnik
  5. Wpisuje wybrana nazwe, klikam “dodaj przycisk” i zadna nowa encja sie nie pojawia

Dla ciekawostki - domyslnie, po dodaniu bramki Sonoffa do AIS, automatem pojawily sie encje Bramka Sonnof Button 1 oraz Bramka Sonoff Status

Czołem też z tym walczę.
W logach mam:

Szczegóły loga (WARNING)

Sun Jan 12 2020 21:41:50 GMT+0100 (czas środkowoeuropejski standardowy)

Problem with b1 to b0 code transfer

Szczegóły loga (ERROR)
Sun Jan 12 2020 22:30:01 GMT+0100 (czas środkowoeuropejski standardowy)
Exception in discovery_callback when dispatching ‘mqtt_discovery_updated_(‘sensor’, ‘42E450_status’)’: ({‘name’: ‘RF status’, ‘state_topic’: ‘dom-6de1_42E450/tele/HASS_STATE’, ‘availability_topic’: ‘dom-6728071a586b5de1_42E450/tele/LWT’, ‘payload_available’: ‘Aktywny’, ‘payload_not_available’: ‘Nieaktywny’, ‘json_attributes_topic’: 'dom-67***de1_42E450/tele/HASS_STATE’, ‘unit_of_measurement’: ’ ', ‘value_template’: “{{value_json[‘RSSI’]}}”, ‘icon’: ‘mdi:information-outline’, ‘unique_id’: ‘42E450_status’, ‘device’: {‘identifiers’: [‘42E450’], ‘connections’: [[‘mac’, ‘84:**********0’]], ‘name’: ‘RF’, ‘model’: ‘Sonoff Bridge’, ‘sw_version’: ‘6.7.1(sonoff)’, ‘manufacturer’: ‘AI-Speaker’}, ‘platform’: ‘mqtt’},)
Traceback (most recent call last):
File “/data/data/pl.sviete.dom/files/usr/lib/python3.7/site-packages/homeassistant/components/mqtt/init.py”, line 1149, in discovery_callback
payload.pop(ATTR_DISCOVERY_HASH)
KeyError: ‘discovery_hash’

Fajnie ze nie jestem sam ze swoim problemem :slight_smile: Zastanawiam sie czy u mnie przyczyna nie jest fakt iz przez wlasna glupote usunalem integracje MQTT :confused:

Zrób nową integracje i podaj IP swojej bramki.

Masz na mysli nowa integracje MQTT? Z wielka checia bym to zrobil ale nie wiem co mam wpisac w polu broker oraz czy uzytkownik/haslo sa dowolne czy tez jakos predefiniowane dla bramek AIS. Zadalem pytanie na ten temat w innym watku: Popsulem MQTT - usunalem z integracji

W polu broker spróbuj wpisać IP bramki a hasło i użytkownika puste zostaw.

nie trzeba nic wpisywać i dodawać ponownie integracji MQTT - wystarczy ponownie uruchomić bramkę, integracja MQTT jest dodana na stałe w parametrach bramki

Fakt :slight_smile: Ale wciaz nie dziala uczenie przyciskow. Malo tego - teraz zauwazylem ze na ekranie konfiguracji bramki RF pojawilo sie pole “Listen to a topic” a ponizej “Topic to subscribe to”. Niewazne czy to pole zostawie puste, czy tez wpisze tam temat, ktory mam wpisany w konfiguracji mojej bramki Sonoff - nic sie dzieje, po kliknieciu przyciskow dodaj przycisk / dodaj czujnik, ine pojawiaja sie zadne nowe encje

@admin.ai-speaker, a możesz kompilować soft, tak żeby od razu jeżeli nie ma skonfigurowanej sieci WIFI był rozgłaszany AP? W oryginalnej Tasmocie tak jest.

Jeszcze jedna ciekawostka - gdy dodaje bramke sonoff rf bridge do AIS, to:

Logi z konsoli:

01:23:43 MQT: dom-xxxxxxxxxxx/tele/LWT = Aktywny (Zachowane)
01:23:43 MQT: dom-xxxxxxxxxxx/cmnd/POWER =
01:25:27 MQT: dom-xxxxxxxxxxx/stat/RESULT = {“SetOption19”:“ON”}
01:25:27 MQT: homeassistant/light/42E3C6_LI_1/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_1/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_2/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_2/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_3/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_3/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_4/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_4/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_5/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_5/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_6/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_6/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_7/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_7/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_8/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_8/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_1/config = {“name”:“Nowe inteligentne gniazdo Button1”,“stat_t”:"~stat/BUTTON1",“avty_t”:"~tele/LWT",“pl_avail”:“Aktywny”,“pl_not_avail”:“Nieaktywny”,“uniq_id”:“42E3C6_BTN_1”,“device”:{“identifiers”:[“42E3C6”],“connections”:[[“mac”,“84:0D:8E:42:E3:C6”]]},"~":“dom-xxxxxxxxxxx/”,“value_template”:"{{value_json.STATE}}",“pl_on”:“TOGGLE”,“off_delay”:1} (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_2/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_3/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_4/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_1/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_2/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_3/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_4/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_5/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_6/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_7/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_8/config = (Zachowane)
01:25:28 MQT: homeassistant/sensor/42E3C6_status/config = {“name”:“Nowe inteligentne gniazdo status”,“stat_t”:"~HASS_STATE",“avty_t”:"~LWT",“pl_avail”:“Aktywny”,“pl_not_avail”:“Nieaktywny”,“json_attributes_topic”:"~HASS_STATE",“unit_of_meas”:" “,“val_tpl”:”{{value_json[‘RSSI’]}}",“ic”:“mdi:information-outline”,“uniq_id”:“42E3C6_status”,“device”:{“identifiers”:[“42E3C6”],“connections”:[[“mac”,“84:0D:8E:42:E3:C6”]],“name”:“Nowe inteligentne gniazdo”,“model”:“Sonoff Bridge”,“sw_version”:“7.1.2(tasmota)”,“manufacturer”:“AI-Speaker”},"~":“dom-xxxxxxxxxxx/tele/”} (Zachowane)
01:25:33 MQT: dom-xxxxxxxxxxx/tele/STATE = {“Time”:“2020-01-14T01:25:33”,“Uptime”:“0T00:04:06”,“UptimeSec”:246,“Heap”:24,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:19,“MqttCount”:2,“Wifi”:{“AP”:1,“SSId”:“moja-siec-wifi”,“BSSId”:“40:31:3C:0B:61:A5”,“Channel”:7,“RSSI”:100,“LinkCount”:1,“Downtime”:“0T00:00:08”}}
01:25:33 MQT: dom-xxxxxxxxxxx/tele/HASS_STATE = {“Version”:“7.1.2(tasmota)”,“BuildDateTime”:“2019-12-07T15:13:35”,“Core”:“2_6_1”,“SDK”:“2.2.2-dev(38a443e)”,“Module”:“Sonoff Bridge”,“RestartReason”:“Software/System restart”,“Uptime”:“0T00:04:06”,“WiFi LinkCount”:1,“WiFi Downtime”:“0T00:00:08”,“MqttCount”:2,“BootCount”:9,“SaveCount”:25,“IPAddress”:“192.168.31.183”,“RSSI”:“100”,“LoadAvg”:19}
01:25:33 MQT: dom-xxxxxxxxxxx/stat/RESULT = {“Version”:“7.1.2(tasmota)”,“BuildDateTime”:“2019-12-07T15:13:35”,“Core”:“2_6_1”,“SDK”:“2.2.2-dev(38a443e)”,“Module”:“Sonoff Bridge”,“RestartReason”:“Software/System restart”,“Uptime”:“0T00:04:06”,“WiFi LinkCount”:1,“WiFi Downtime”:“0T00:00:08”,“MqttCount”:2,“BootCount”:9,“SaveCount”:25,“IPAddress”:“192.168.31.183”,“RSSI”:“100”,“LoadAvg”:19}

my mamy opcję WifiConfig == 4
disable Wi-Fi Manager but retry the other AP without rebooting

tasmota ma WifiConfig == 2
set Wi-Fi Manager as the current configuration tool and start Wi-Fi Manager (web server at 192.168.4.1) for 3 minutes, then reboot and try to connect Wi-Fi network

Ze względów bezpieczeństwa nie chcemy stawiać AP bez wiedzy użtykownika.
(nie chcemy, żeby urządzenie samo robiło się AP przy braku sieci)

Tu jest opis:

podczas dodawania urzadzenie bramka:

  1. rozłącza się z sieci wifi X
  2. łączy do sieci WiFI urządzenia (które podczas konfiguracji jest AP)
  3. ponownie łączy się z siecą wifi X

w tym czasie Ty na swoim komputerze jesteś połączony ciągle z wifi X
co oznacza, że w punkcie 2 nie masz połączenia z bramką

dlatego ten komunikat w aplikacji - pomimo, że wszsytko jest OK
gdybyś robił to na bramce (podłączonej do monitora / tv) to nie było by takiego komunikatu

Oczywiście postaramy się to jakoś poprawić, bo faktycznie nie jest to tak jasne dla użytkowników jak dla nas :wink: