Wyjaśnienie jak działa komunikacja urządzeń z bramką. MQTT Explorer - Fajne narzędzie do MQTT

Mam ale Ja edytuję w Visual Studio Code i platformio

Mam pytanie jeśli mam mostek hue w sieci to mogę gniazdku ustawić emulacje Mosteh Hue Multi urządzenie? i pytanie czy będzie widoczny z kontrolerze hue ? albo bedzie wykorzystywał zigbee z żarówek ?

Zrobiłem Tuya-convert, tasmota wgrala się 9.2.0,
wszytsko ustawiłem jak trzeba i klops, AIS nie wykrywa automatycznie…?
Po godzinnych cudowaniach, rekonfiguracjach, robienia bridgów mqtt zauważyłem w mqtt explorer, że SetOption19 1 nie daje nic w prefixie homeassistant, kliknąłem update tasmoty, wgrało się 9.5.0, zaczęło dobrze nadawać i od razu wykryło.
Piszę bo ktoś moze mieć podobny problem :slight_smile:

2 polubienia

Czy jesteś na Tasmota w oryginale czy wersji od AIS?
Ważny jest jeszcze tamat mqtt - na bramce to “dom”
Więc po wgraniu Tasmota dwie komendy obowiązkowe:
SetOption 19
GroupTopic dom
Tasmota od AIS ma to wystawione w standardzie.

Oczywiście :slight_smile:
Mam wszystko na tasmocie i nigdy nie było problemu.
Mam normalne tasmoty,
Po tuya-convert zainstalowała sie tasmota i ją skonfigujrowałem i ewidentnie było cos z nią nie tak,
w eksplorerze normalnie była, ale w prefiksie homeassistant nic nie nadawała czyli się nie przedstawiała… tylko kliknąłem update automatyczny i od razu wykryło

To sa moje standardowe komendy do nowej tasmoty:

TelePeriod 30
SetOption30 1 - jeśli light
GroupTopic dom 
SetOption19 1 
SetOption65 1 
PowerOnState 0 
1 polubienie

Coś jest nie do końca z tymi binarkami od TuyaConvert w porządku.
Proponuję jeszcze wykonać dla pewności reset2 1 Zalecają na stronie Tasmota reset5, mieliśmy wcześniej problemy ze znikającą konfiguracją wi-fi po zaniku napięcia na gniazdkach SP111…

1 polubienie

Czyli

reset2 1
#potem
reset5 1

i skonfigurować… tak?

Reset komendy do wyboru:

To jest ten fragment z dokumentacji Tasmota:

Ale ja zamiast reset5 proponuję reset2 - czyli pójść dalej i wyczyścić prawie wszystko.

1 polubienie

Cezary jak rozwiązałeś problem ze znikającą konfiguracją wifi po zaniku prądu tasmota 9,5 właśnie wstałem i nie mam 12 żarówek :slight_smile:

Nie pamiętam czy jest na to inna metoda niż aktualizacja Tasmota. Przy wersji 9.5 nie powinno być problemu. Ale jak była dyskoteka od elektrowni, to może być różnie. Wgrałem na nowo Tasmota od AIS po kabelku. Wiem, że będzie to raczej niemożliwe przy “żarówkach” LED, dlatego ich nie stosuje.
Wypróbuj procedure re-covery (7 razy wyłączyć i włączyć zasilanie):

https://tasmota.github.io/docs/Device-Recovery/#fast-power-cycle-device-recovery

Jeszcze jedno… z jednym gniazdkiem SP-111 miałem więcej powtarzających się problemów. W jego przypadku pomagało tylko przywrócenie konfiguracji z pliku kopi po OTA.

ogarnięte dzięci Cezary.K

A co zadziałało? Jak sobie poradziłeś? Generalnie po zwykłym zaniku napięcia nie ma problemów z Tasmota. Powracają do sieci nie gubiąc konfiguracji wi-fi. Ona jest wpisana w pamięci nieulotnej modułu.
Ale jeśli zaniki napięcia są pulsacyjne, to właśnie dają objaw przechodzenia do funkcji fast-power-cycle-device-recovery