AIS serwis Spotify problem z dodaniem tej integracji

Mam problem. Nie mogę dodać integracji AIS serwis Spotify, wyskakuje mi błąd: 500 Internal Server Error
Server got itself in trouble. Integracja mi znikła, chyba po ostatniej najnowszej aktualizacji. Co ciekawe gdy Jolka podłączona do telewizora po HDMI, wybieram “Sterowanie na monitorze” i włączę ikonę Spotify to połączę się z serwisem i gra muza, natomiast z apk czy po http: jak włączę Spotify problem błąd połączenia. Może pomożecie rozwiązać mój problem?

Cześć @Tadek

tak, w wersji 0.116 wdarł się peien błąd… postanowiliśmy nie włączać Spotify domyślnie dla wszystkich w konfiguracji (bo to wymaga odświeżania tokena i zajmuje czas przy starcie… a przecież nie każdy ma włączone Spotify)… niestety to nie do końca dobrze zostało to domyślne uruchamianie wyłaczone i może to powodować ten błąd.
Poprawiliśmy to w wersji 0.117… która jest na beta.

Żeby to naprawić u Ciebie są 3 opcje do wyboru:

  1. Czekamy aż pojawi się 0.117 na stablinym i po aktualizacji będzie ok

  2. Dodajesz do konfiguracji wpis ais_spotify_service:
    w pliku ~/AIS/configuration.yaml na końcu dodajesz jedną linijkę:

ais_spotify_service:

następnie restart usługi ais komendą

pm2 restart ais

po ponownym uruchomienie systemu będzie OK

  1. Instalujemy betę,
    w konsoli wpisujesz taką komendę
pip install ais-dom==0.117.5b0 -U

czekasz aż skończy a następnie komenda

pm2 restart ais

po ponownym uruchomienie systemu będzie OK

Zaktualizowałem do wersji beta 0.117 wg. wskazań. Integracja AIS serwis Spotify przeszła nie ma “błędu 500”, już ją mogłem zainstalować. Jolka widzi utwory z Spotify czego wcześniej nie było, ale problem brak dźwięku. Radio gra, yutube gra a Spotify milczy. Jak wybieram “Sterowanie na monitorze” i włączę ikonę Spotify to połączę się z serwisem i gra muza, natomiast z apk czy po http: jak włączę Spotify brak dźwięku.

Każdy ma tak samo. Muzyka gra na wyjściu z bramki - podłącz głośnik bezpośrednio i będziesz słyszał muzykę :wink:

Mam podłączony głośnik bezpośrednio i nie gra, wcześniej było ok.

Poradziłem sobie, odtworzyłem kopię zapasową teraz jest ok, mam sterowanie i odtwarzanie Spotify z smartfona. :grinning:

Cześć,

Mam problem z integracją spotify. Aplikacja działał na bramce od jakiegoś czasu. Jednak ostatnimi czasy jej nie używałem … dziś chciałem uruchomić muzykę w Spotify okazało się że integracja znikła. Nie zastanawiając się zbyt długo pobrałem integrację ponownie, teoretycznie się zainstalowała ale jednak nie do końca.
W logach widnieją takie błędy

Co dziwne w zakładce integracje aplikacja wyświetla się jako nie wczytana, brak możliwości odinstalowania ani konfiguracji (brak rozwijanego menu z kropeczkami) . Jest na to jakiś sposób?
Odinstalowanie z konsoli? lub reinstalacja?
obraz