Czy głowica termostatyczna do kaloryfera Tuya ZigBee zadziała?

Znalazlem taka glowice:
https://botland.com.pl/pl/tuya-automatyka-domowa/17148-tuya-inteligentna-glowica-termostatyczna-zigbee.html?search_query=glowica&results=11

Czy zadziała taka głowica przez ZigBee USB dongle podłączone do bramki?
Czy trzeba zmieniać soft w głowicy?

Zigbee to zigbee. Tu się softu nie zmienia i dlatego też jest to takie super. Musisz tylko sprawdzić, czy twoja bramka zigbee ją obsługuje.

Ktoś to przetestował? Też mnie interesuje ta głowica…

Zigbee to tylko protokół transmisji bezprzewodowej, podobnie jak wifi.
Moje pytanie bierze się stąd, że nie każde urzadzenie wifi będzie pracowało a bramką AIS a przecież “wifi to wifi” :wink:
I tak aby aby np. moduł SONOFF albo Tuya pracował z bramką AIS musi być w nim wgrane opowiednie oprogramowania np. Tasmota-Sonoff. Samo wifi nic tu nie da kiedy oprogramowanie uradzenia nie wie jak sie komunikowac z bramką np. przez protokół wyższej warstwy MQTT.

Dlatego pytałem czy ta głowica termostatyczna Tuya ZigBee zostanie rozpoznana przez bramkę AIS z wpiętym ZigBee USB dongle?

Wifi to inna bajka i Zigbee też… Zigbee wystarczy że jest obsługiwane przez zigbee2mqtt https://www.zigbee2mqtt.io/information/supported_devices.html jeśli masz dongla USB Zigbee i już. Z Wifi to musi być soft który współpracuje z HA. Zalecana jest tasmota bo soft np. Tuya i inne niezbyt dobrze współpracują z HA i nie każdy soft da się prosto przeprogramować np. na Tasmotę…

No i właśnie o mam problem z głowicą, o którą pytałem w pierwszym poście.
Uruchomiłem, sparowałem z bramką, bramka rozpoznała nowe urządzenie, ale w logach mam:

5|zigbee | Zigbee2MQTT:warn 2020-08-17 00:16:38: Received message from unsupported device with Zigbee model ‘GbxAXL2’
5|zigbee | Zigbee2MQTT:warn 2020-08-17 00:16:38: Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html.

Dlatego pytałem przed zakupem, w pierwszym poście, czy zadziała ta głowica z Botland-u ?

Rozwiązałeś temat? znalazłem jakiś komentarz na allegro, ze nie działa z zigbee2mqtt

Podbijam temat. Z tego co wygooglalem

  • glowica Tuya wspolpracuje tylko z hubem zigbee z firmy tuya - zibgee2mqtt czy bramki zigbee od sonoffa czy xiaomi nie sa wspierane
  • bramka Tuya zigbee nie wspolpracuje z HA. Nawet na stronie integracji HA/Tuya, jest komentarz The tuya integration is the main integration to integrate all Tuya Smart related platforms, except the Zigbee hub

Ktos przetestowal

Jestem totalnym laikiem i dopiero zaczynam zabawę z AIS.
Dziś kupiłem głowicę GS361A-H04 Siterwell i dodałem ją do zigbee2mqtt i generalnie działa, choć jeszcze nie do końca ogarnąłem kwestie ustawień i automazycji.

Czasami jedynie na panelu głównym gdzie mam kartę termostat wygląda jakby nie odczytywała bieżących nastawów ( wszystko jest na szaro) i nie wiem czym to jest spowodowane.

Zasięg zigbee mam imo dobry, bo od dawna jestem użytkownikiem hue i w zasadzie urządzenia zigbee mam w całym domu, chociaż integrację hue mam bezpośrednio z AiS, nie zigbee2mqtt ( na mapie nie widać hue)

Masz na mysli glowice opisana tutaj: https://hejdom.pl/blog/17-tuya/237-tuya-zigbee-glowica-termostatyczna-gtz02.html ? Kupowales w PL czy na aliexpress/gearbest?
Wlasnie wygooglalem tez inne glowice Tuya, ktore sa wspierane przez HA - poszukam czegos z darmowym zwrotem i przetestuje :slight_smile:

Tak, to ta. Kupiona w Pl

a nie myślałeś o tych: https://allegro.pl/oferta/tuya-inteligentna-glowica-termostatyczna-na-wifi-9665242363 ??
Powinna działać z mqtt https://www.zigbee2mqtt.io/devices/TS0601_thermostat.html

@lyczko no właśnie zakupiłem tą głowicę (na razie jedną na próbę). ZigBee w bramce wykryło głowicę bez problemu i chyba są wszystkie jej encje. Problem jednak w tym, że z poziomu bramki (HA) nie da się sterować tą głowicą. Przy próbie np. zmiany temperatury czy trybu pracy głowicy po kilku sekundach nastawy wracają do stanu pierwotnego. Nie wiem czy to błąd w trakcie dodawania głowicy czy coś innego. Próbowałem usunąć głowicę i dodać ją na nowo, ale nic to nie pomogło. Jak zmienię nastawy w samej głowicy to bramka natychmiast je aktualizuje, a w drugą stronę nie działa. Macie może jakieś pomysły? Może AIS TEAM ma jaki s pomysł jak to ogarnąć?

Na dobry początek zbierz logi z zigbee w konsoli:
pm2 logs zigbee
W drugim okienku ustaw temperaturę w HA i poczekaj aż się przywróci. Wrzuć tutaj logi.

$ pm2 logs zigbee
[TAILING] Tailing last 15 lines for [zigbee] process (change the value with --lines option)
[PM2][ERROR] No file to stream for app [zigbee], exiting.

Mam taki komunikat po wpisaniu komendy pm2 logs zigbee

Tak, ale proces powinien działać dalej i logi powinny się zbierać na konsolę wtedy.

Proces się zatrzymuje… No file to stream for app [zigbee], exiting.

8|zigbee | Zigbee2MQTT:info 2020-09-23 15:14:24: MQTT publish: topic ‘zigbee2mqtt/ Termostat salon’, payload ‘{“auto_lock”:“MANUAL”,“away_preset_days”:1,“away_preset_temperature”:15,“boost_time”:300,“child_lock”:“UNLOCKED”,“comfort_temperature”:20,“current_heating_setpoint”:“22.0”,“eco_temperature”:15,“force”:“normal”,“holidays”:[{“hour”:6,“minute”:0,“temperature”:20},{“hour”:8,“minute”:0,“temperature”:15},{“hour”:11,“minute”:30,“temperature”:15},{“hour”:12,“minute”:30,“temperature”:15},{“hour”:17,“minute”:30,“temperature”:20},{“hour”:22,“minute”:0,“temperature”:15}],“linkquality”:36,“local_temperature”:“21.0”,“local_temperature_calibration”:"-3.0",“max_temperature”:35,“min_temperature”:5,“position”:90,“preset”:“manual”,“system_mode”:“manual”,“week”:“7”,“window_detection”:“OFF”,“window_detection_params”:{“minutes”:10,“temperature”:5},“workdays”:[{“hour”:6,“minute”:0,“temperature”:20},{“hour”:8,“minute”:0,“temperature”:15},{“hour”:11,“minute”:30,“temperature”:15},{“hour”:12,“minute”:30,“temperature”:15},{“hour”:17,“minute”:30,“temperature”:20},{“hour”:22,“minute”:0,“temperature”:15}]}’
8|zigbee | Zigbee2MQTT:info 2020-09-23 15:14:25: MQTT publish: topic ‘zigbee2mqtt/ Termostat salon’, payload ‘{“auto_lock”:“MANUAL”,“away_preset_days”:1,“away_preset_temperature”:15,“boost_time”:300,“child_lock”:“UNLOCKED”,“comfort_temperature”:20,“current_heating_setpoint”:“22.0”,“eco_temperature”:15,“force”:“normal”,“holidays”:[{“hour”:6,“minute”:0,“temperature”:20},{“hour”:8,“minute”:0,“temperature”:15},{“hour”:11,“minute”:30,“temperature”:15},{“hour”:12,“minute”:30,“temperature”:15},{“hour”:17,“minute”:30,“temperature”:20},{“hour”:22,“minute”:0,“temperature”:15}],“linkquality”:36,“local_temperature”:“21.0”,“local_temperature_calibration”:"-3.0",“max_temperature”:35,“min_temperature”:5,“position”:90,“preset”:“manual”,“system_mode”:“manual”,“week”:“7”,“window_detection”:“OFF”,“window_detection_params”:{“minutes”:10,“temperature”:5},“workdays”:[{“hour”:6,“minute”:0,“temperature”:20},{“hour”:8,“minute”:0,“temperature”:15},{“hour”:11,“minute”:30,“temperature”:15},{“hour”:12,“minute”:30,“temperature”:15},{“hour”:17,“minute”:30,“temperature”:20},{“hour”:22,“minute”:0,“temperature”:15}]}’

To są logi po komendzie pm2 logs…

Właśnie miałem napisać żebyś dał wtedy to polecenie :slight_smile:
A w międzyczasie wykonałeś jakąś operację na encji climate?