Zigbee, usuwanie urządzeń

Witam, próbuje usunąć urządzenie zigbee przez opcje usuń encje ale to nie działa. Czy urządzenia zigbee usuwa się w innym miejscu?

U mnie też tak nie działało ale po resecie urządzenia gdy nie jest już sparowane i restarcie bramki, można nieaktywne encje urządzeń usunąć.

Usuwamy w tym miejscu. Proszę sprawdzić logi na bramce podczas usuwania, prawdopodobnie urządzenie nie opowiedziało na komendę:

pm2 logs

lub

pm2 logs zigbee 

Powinien pojawić się jakiś kod błędu. Ten kod błędu proszę poszukać w dokumentacji Zigbee2MQTT, tam powinno być wyjaśnienie jak rozwiązywać tego typu problemy (co robić żeby było OK):

Czujnik światła Xiaomi GZCGQ01LM opisany np. tutaj https://homekitnews.com/2020/01/27/mi-light-sensor-review/ podczas dodawania generuje raczej jasny komunikat. Tylko nie za bardzo umiem dodać jego obsługę. Może ktoś pomoże?

8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:13: Zigbee: allowing new devices to join.
8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:13: MQTT publish: topic ‘zigbee2mqtt/bridge/config’, payload ‘{“version”:“1.8.0”,“commit”:“unknown”,“coordinator”:{“type”:“zStack12”,“meta”:{“transportrev”:2,“product”:0,“majorrel”:2,“minorrel”:6,“maintrel”:3,“revision”:20190608}},“log_level”:“info”,“permit_join”:true}’
8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:31: Device ‘czujnik’ joined
8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:31: MQTT publish: topic ‘zigbee2mqtt/bridge/log’, payload ‘{“type”:“device_connected”,“message”:{“friendly_name”:“czujnik”}}’
8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:31: Starting interview of ‘czujnik’
8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:31: MQTT publish: topic ‘zigbee2mqtt/bridge/log’, payload ‘{“type”:“pairing”,“message”:“interview_started”,“meta”:{“friendly_name”:“czujnik”}}’
8|zigbee | zigbee2mqtt:warn 2020-02-03 19:27:35: Received message from unsupported device with Zigbee model ‘lumi.sen_ill.mgl01’
8|zigbee | zigbee2mqtt:warn 2020-02-03 19:27:35: Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html.
8|zigbee | zigbee2mqtt:warn 2020-02-03 19:27:36: Received message from unsupported device with Zigbee model ‘lumi.sen_ill.mgl01’
8|zigbee | zigbee2mqtt:warn 2020-02-03 19:27:36: Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html.
8|zigbee | zigbee2mqtt:warn 2020-02-03 19:27:39: Received message from unsupported device with Zigbee model ‘lumi.sen_ill.mgl01’
8|zigbee | zigbee2mqtt:warn 2020-02-03 19:27:39: Please see: https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html.
8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:39: Successfully interviewed ‘czujnik’, device has successfully been paired
8|zigbee | zigbee2mqtt:warn 2020-02-03 19:27:39: Device ‘czujnik’ with Zigbee model ‘lumi.sen_ill.mgl01’ is NOT supported, please follow https://www.zigbee2mqtt.io/how_tos/how_to_support_new_devices.html
8|zigbee | zigbee2mqtt:info 2020-02-03 19:27:39: MQTT publish: topic ‘zigbee2mqtt/bridge/log’, payload ‘{“type”:“pairing”,“message”:“interview_successful”,“meta”:{“friendly_name”:“czujnik”,“supported”:false}}’

Z żarówkami z IKEA nie ma problemu ale jak obsłużyć pilota ZigBee Tradfri z IKEA ? Sparowany jest i na diagramie go widać poza tym nigdzie w stanach nie występuje.

A u nas pilot działa :wink:


Spróbuj sparować ponownie z włączonymi logami:

pm2 logs zigbee

Zdarza się jednak, że po sparowaniu urządzenie nie jest poprawnie przedstawiane do HA - np. leci błąd: Failed to execute LQI for … i wówczas nie założy encji.

1polubienie

Jest już oficjalnie wspierany przez zigbee2mqtt:


dodany dwa tygodnie temu i będzie w kolejnej wersji: 1.9.0 (aktualnie mamy 1.8.0)

1polubienie

Dziękuję za pomoc :slight_smile:

1polubienie

U mnie już też. usunąłem go w końcu i dodałem od nowa. Chyba źle go parowałem bo przez naciśnięcie 4x przycisku a nie przez przytrzymanie go przez 10 sekund.

1polubienie

@mozimek udało Ci się usunąć ?
Mam ten sam problem i nie mogę sobie z nim poradzić…

Mi się jeszcze nie udało. Latają mi takie wolne elektrony :confused:

Czesc, tak ale pośrednio. Mam bramkę zigbee Xiaomi. Usuwam w naszej bramce dodaję urządzenie do bramki Xiaomi i wtedy znika. Cwiczyłem to już dwa razy.

Jakis czas temu przywrocilem ustawienia fabryczne i nie mialem czasu bawic sie z zigbee. Teraz wrocilem do tematu i mam problem :confused:

  1. Dongle Zigbee dziala - po wlozeniu dongla slsyze komuinikat o uruchomieniu serwisu zigbee
  2. Przycisk Xiaomi (Mi wireless witch) jest wykrywany przez Jolke, aczkolwiek dopiero za n-tym podejsciem. Moge go zobaczyc na mapie urzadzen zigbee. Niestety, wszystkie powiazane encje maja status ‘nieznany’
    image
    W zwiazku z tym brak mozliwosci obslugi zdarzen i tworzenia automatyzacji
  3. Mi Cube - w ogole nie jest wykrywana przez Jolke. Tak, klikam przycisk odswiez :slight_smile: Aczkolwiek byl wykrywany wczesinej. Jest tez wykrywany poprzez bramke Xiaomi - zatem kostka jest sprawna
  4. pm2 twierdzi ze nie ma zadnych informacji na temat uslugi zigbee
    $ pm2 logs zigbee
    [TAILING] Tailing last 15 lines for [zigbee] process (change the value with --lines option)
    [PM2][ERROR] No file to stream for app [zigbee], exiting.

1 Jolka raczej tu nie ma nic do rzeczy.
2 Włącz sobie logi debug i popatrz co tam widać podczas klikania przyciskami.
3. Sparować z zigbee2mqtt powinien się każdy device zigbee
4 Jeśli masz możliwość to polecam gdzieś obok postawić Zigbee2mqttAssistant - dużo przyjemniejsza obsługa, mapa wygląda znacznie lepiej niż na załączonym obrazku.

Miałem teraz chwilkę to mogłem się przełączyć na sieć domową żeby zrobić screeny.
Tak wygląda sieć w Zigbee2MqttAssistant


Masz też zarządzanie PermitJoin i poziomem logowania

No i to co pozwala na intuicyjną zabawę z urządzeniami:

Dzieki za podpowiedz, postwie sobie Zigbee2MqttAssistant na innej maszynie.

Jak moge wlaczyc logi debug? Jak pisalem - jedno urzadzenie sie nie dodaje wcale, drugie sie dodaje, ale jest ‘niepelnowartosciowe’.

Wyślij “debug” na temat podany poniżej. Narzędzia deweloperskie > MQTT > Opublikuj pakiet