🦁 Leon wydanie na PROD

Pierwszy wpis z Twojego loga zgłaszałem w Alfie.

@Goral64
image
Masz w sieci lokalnej bramki, które nazywają się tak samo.

Mam 3 i nazwy mają domyślne, ale to nie jest jakiś znaczący problem, bo mam je w lokalnym DNS.

Ale używanie przy tym multicast DNS może generować potencjalne (niepotrzebne) problemy, w sieci ethernet nie jest zalecane aby działały urządzenia o tej samej nazwie, to tylko takie podstawy ale każdy może robić co sobie chce :slight_smile: .

1 polubienie

Dodatkowo posypała mi się integracja z Suplą i część urządzeń/encji jest niedostepna.
Także Zigbee2MQTT oberwało gdyż znowu nie aktualizują się stany encji choć sterowanie działa.

Tutaj pomogło wprowadzenie zmiany w dowolnym kanale w Supli i wszystko się zaktualizowało po MQTT.
Pozostaje jeszcze Zigbee2MQTT ale muszę znaleźć post na tym forum, bo chyba zapisałem jak poprzednim razem to naprawiłem… a teraz zapomniałem :frowning:
Znalazłem niestety tylko to… a mam 55 modułów Zigbee :frowning:

Mam ten sam problem z aktualizacją. Android został na wersji 3.0.0

Ani z aplikacji ani z konsoli nie daje się zaktualizować. Restart również wymuszam komendą w konsoli.

3 polubienia

Mam dokładnie to samo, reszta chodzi bez problemu.

Znalazł ktoś rozwiązanie?

a u mnie na BETA jakby poszło, ręczny restart tylko musiałem zrobić

U mnie też poszło ale z ALFY gdzie android 3.0.1 był wcześniej lecz reset jak u przedmówcy ręcznie.

Również wszystko poszło bez problemów ale reset jak wyżej, ręcznie.

U mnie niestety bez zmian, choć w sumie nie do końca, bo pojawił się restart… ale aktualizacja Andka nieudana :frowning:


Logi oznajmiają coś takiego:

2|ais     |  ANDROID SCREEN APP
2|ais     | ok
2|ais     |  Pobieram i instaluje Android Screen APK...
2|ais     | avc:  denied  { read } for  scontext=u:r:system_server:s0 tcontext=u:object_r:sdcardfs:s0 tclass=file permissive=1
2|ais     | Success
2|ais     |  ANDROID   versionName=3.0.1
2|ais     |  Pobieram i instaluje Android ...
2|ais     | ok
2|ais     | Starting: Intent { cmp=launcher.sviete.pl.domlauncherapp/.LauncherActivity (has extras) }
2|ais     | Warning: Activity not started, intent has been delivered to currently running top-most instance.

Pominąłem tu uaktualnienia statusów i progresy pobierania, ale co ciekawe ostatnie dwie linijki wyświetliły się w trakcie pobierania (chyba instalatora Andka…)
Jeśli jedynym wyjściem okaże się instalacja bramki od nowa, to trochę to słabe :frowning:

U mnie taka sama sytuacja. Bramka już się restartuje ale android się nie aktualizuje.

U mnie w ogóle nie wykrywa aktualizacji. DEV3

nowe wydane to coś musi być skopane :grin:

dzięki za info - już wiadomo o co chodzi, brak aktualizacji Androida i brak automatycznego restartu to ten sam problem

na ota nie podmieniliśmy wersji prod apki i instalujemy starszą wersje,
Android widzi, że wersja apki się nie zmianiła i nie robi restartu serwera

to dotyczy kanału PROD, na alfa i beta powinno być ok

jutro to naprawie i będzie można jeszcze raz kliknąć w aktualizacje i będzie ok,
a w ramach obejścia można dzisiaj w konsoli taką komendę wkleić:

su -c 'am start -n launcher.sviete.pl.domlauncherapp/.LauncherActivity -e command ais-dom-update-beta'
4 polubienia

Poczekam, to akurat może poczekać. Najbardziej wkurza mnie niestabilność ais. Dostęp do www się przycina, czasem na kilka minut, encje się nie odświeżają… A zigbee miało nawet 135 sekundowy lag przy włącz/wyłącz…Nie tego oczekiwałem po PRO1 :frowning:

1 polubienie

OK, kolejna próba aktualizacji bramek o brakująca aktualizację Androida (z konsoli SSH).
Na wszystkich bramkach aktualizacja się tym razem powiodła, ale na DEV3 i PRO1 mimo wszystko wystąpiły pod koniec skryptu problemy. No i na PRO1 jak zwykle posypały się encje Supli i Zigbee2MQTT czyli jedyne powody używania bramki :frowning:
DEV1:

 ZIGBEE   "version": "1.22.1",
 Zigbee OK...
 OK. Instalacja trwała  99 sekund
ok ANDROID SCREEN APP
ok Pobieram i instaluje Android Screen APK...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   142  100   142    0     0    281      0 --:--:-- --:--:-- --:--:--   281
100   153  100   153    0     0    143      0  0:00:01  0:00:01 --:--:--   143
100 3356k  100 3356k    0     0   889k      0  0:00:03  0:00:03 --:--:-- 1407k
Success
 ANDROID   versionName=3.0.1
 Android OK...
 Restartuje usługę ais ...
ok~ $ 

… i restart bez rozłączenia konsoli
DEV3:

 ZIGBEE   "version": "1.22.1",
 Zigbee OK...
 OK. Instalacja trwała  52 sekund
ok ANDROID SCREEN APP
ok Pobieram i instaluje Android Screen APK...
avc:  denied  { read } for  scontext=u:r:system_server:s0 tcontext=u:object_r:sdcardfs:s0 tclass=file permissive=1
Success
 ANDROID   versionName=3.0.1
 Pobieram i instaluje Android ...
okStarting: Intent { cmp=launcher.sviete.pl.domlauncherapp/.LauncherActivity (has extras) }
Warning: Activity not started, intent has been delivered to currently running top-most instance.
~ $

… i restart z rozłączeniem konsoli
PRO1:

 ZIGBEE   "version": "1.22.1",
 Zigbee OK...
 OK. Instalacja trwała  39 sekund
ok ANDROID SCREEN APP
ok Pobieram i instaluje Android Screen APK...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   142  100   142    0     0    397      0 --:--:-- --:--:-- --:--:--   398
100   153  100   153    0     0    175      0 --:--:-- --:--:-- --:--:--  149k
100 3356k  100 3356k    0     0  1539k      0  0:00:02  0:00:02 --:--:-- 3105k
avc:  denied  { read } for  scontext=u:r:system_server:s0 tcontext=u:object_r:sdcardfs:s0 tclass=file permissive=1
Success
 ANDROID   versionName=3.0.1
 Pobieram i instaluje Android ...
okStarting: Intent { cmp=launcher.sviete.pl.domlauncherapp/.LauncherActivity (has extras) }
Warning: Activity not started, its current task has been brought to the front
~ $

… i restart z rozłączeniem konsoli

Zmieniłem kanał na BETA, zaktualizowałem i teraz w ogóle zigbee2mqtt się nie chce włączyć.
Restart bramki nie pomaga. DEV3
pm2 logs pokazuje tylko to: