Sonoff RF Bridge oraz soft AI Speaker

Fajnie ze nie jestem sam ze swoim problemem :slight_smile: Zastanawiam sie czy u mnie przyczyna nie jest fakt iz przez wlasna glupote usunalem integracje MQTT :confused:

Zrób nową integracje i podaj IP swojej bramki.

Masz na mysli nowa integracje MQTT? Z wielka checia bym to zrobil ale nie wiem co mam wpisac w polu broker oraz czy uzytkownik/haslo sa dowolne czy tez jakos predefiniowane dla bramek AIS. Zadalem pytanie na ten temat w innym watku: Popsulem MQTT - usunalem z integracji

W polu broker spróbuj wpisać IP bramki a hasło i użytkownika puste zostaw.

nie trzeba nic wpisywać i dodawać ponownie integracji MQTT - wystarczy ponownie uruchomić bramkę, integracja MQTT jest dodana na stałe w parametrach bramki

Fakt :slight_smile: Ale wciaz nie dziala uczenie przyciskow. Malo tego - teraz zauwazylem ze na ekranie konfiguracji bramki RF pojawilo sie pole “Listen to a topic” a ponizej “Topic to subscribe to”. Niewazne czy to pole zostawie puste, czy tez wpisze tam temat, ktory mam wpisany w konfiguracji mojej bramki Sonoff - nic sie dzieje, po kliknieciu przyciskow dodaj przycisk / dodaj czujnik, ine pojawiaja sie zadne nowe encje

@admin.ai-speaker, a możesz kompilować soft, tak żeby od razu jeżeli nie ma skonfigurowanej sieci WIFI był rozgłaszany AP? W oryginalnej Tasmocie tak jest.

Jeszcze jedna ciekawostka - gdy dodaje bramke sonoff rf bridge do AIS, to:

Logi z konsoli:

01:23:43 MQT: dom-xxxxxxxxxxx/tele/LWT = Aktywny (Zachowane)
01:23:43 MQT: dom-xxxxxxxxxxx/cmnd/POWER =
01:25:27 MQT: dom-xxxxxxxxxxx/stat/RESULT = {“SetOption19”:“ON”}
01:25:27 MQT: homeassistant/light/42E3C6_LI_1/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_1/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_2/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_2/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_3/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_3/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_4/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_4/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_5/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_5/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_6/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_6/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_7/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_7/config = (Zachowane)
01:25:27 MQT: homeassistant/light/42E3C6_LI_8/config = (Zachowane)
01:25:27 MQT: homeassistant/switch/42E3C6_RL_8/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_1/config = {“name”:“Nowe inteligentne gniazdo Button1”,“stat_t”:"~stat/BUTTON1",“avty_t”:"~tele/LWT",“pl_avail”:“Aktywny”,“pl_not_avail”:“Nieaktywny”,“uniq_id”:“42E3C6_BTN_1”,“device”:{“identifiers”:[“42E3C6”],“connections”:[[“mac”,“84:0D:8E:42:E3:C6”]]},"~":“dom-xxxxxxxxxxx/”,“value_template”:"{{value_json.STATE}}",“pl_on”:“TOGGLE”,“off_delay”:1} (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_2/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_3/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_BTN_4/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_1/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_2/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_3/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_4/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_5/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_6/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_7/config = (Zachowane)
01:25:28 MQT: homeassistant/binary_sensor/42E3C6_SW_8/config = (Zachowane)
01:25:28 MQT: homeassistant/sensor/42E3C6_status/config = {“name”:“Nowe inteligentne gniazdo status”,“stat_t”:"~HASS_STATE",“avty_t”:"~LWT",“pl_avail”:“Aktywny”,“pl_not_avail”:“Nieaktywny”,“json_attributes_topic”:"~HASS_STATE",“unit_of_meas”:" “,“val_tpl”:”{{value_json[‘RSSI’]}}",“ic”:“mdi:information-outline”,“uniq_id”:“42E3C6_status”,“device”:{“identifiers”:[“42E3C6”],“connections”:[[“mac”,“84:0D:8E:42:E3:C6”]],“name”:“Nowe inteligentne gniazdo”,“model”:“Sonoff Bridge”,“sw_version”:“7.1.2(tasmota)”,“manufacturer”:“AI-Speaker”},"~":“dom-xxxxxxxxxxx/tele/”} (Zachowane)
01:25:33 MQT: dom-xxxxxxxxxxx/tele/STATE = {“Time”:“2020-01-14T01:25:33”,“Uptime”:“0T00:04:06”,“UptimeSec”:246,“Heap”:24,“SleepMode”:“Dynamic”,“Sleep”:50,“LoadAvg”:19,“MqttCount”:2,“Wifi”:{“AP”:1,“SSId”:“moja-siec-wifi”,“BSSId”:“40:31:3C:0B:61:A5”,“Channel”:7,“RSSI”:100,“LinkCount”:1,“Downtime”:“0T00:00:08”}}
01:25:33 MQT: dom-xxxxxxxxxxx/tele/HASS_STATE = {“Version”:“7.1.2(tasmota)”,“BuildDateTime”:“2019-12-07T15:13:35”,“Core”:“2_6_1”,“SDK”:“2.2.2-dev(38a443e)”,“Module”:“Sonoff Bridge”,“RestartReason”:“Software/System restart”,“Uptime”:“0T00:04:06”,“WiFi LinkCount”:1,“WiFi Downtime”:“0T00:00:08”,“MqttCount”:2,“BootCount”:9,“SaveCount”:25,“IPAddress”:“192.168.31.183”,“RSSI”:“100”,“LoadAvg”:19}
01:25:33 MQT: dom-xxxxxxxxxxx/stat/RESULT = {“Version”:“7.1.2(tasmota)”,“BuildDateTime”:“2019-12-07T15:13:35”,“Core”:“2_6_1”,“SDK”:“2.2.2-dev(38a443e)”,“Module”:“Sonoff Bridge”,“RestartReason”:“Software/System restart”,“Uptime”:“0T00:04:06”,“WiFi LinkCount”:1,“WiFi Downtime”:“0T00:00:08”,“MqttCount”:2,“BootCount”:9,“SaveCount”:25,“IPAddress”:“192.168.31.183”,“RSSI”:“100”,“LoadAvg”:19}

my mamy opcję WifiConfig == 4
disable Wi-Fi Manager but retry the other AP without rebooting

tasmota ma WifiConfig == 2
set Wi-Fi Manager as the current configuration tool and start Wi-Fi Manager (web server at 192.168.4.1) for 3 minutes, then reboot and try to connect Wi-Fi network

Ze względów bezpieczeństwa nie chcemy stawiać AP bez wiedzy użtykownika.
(nie chcemy, żeby urządzenie samo robiło się AP przy braku sieci)

Tu jest opis:

podczas dodawania urzadzenie bramka:

  1. rozłącza się z sieci wifi X
  2. łączy do sieci WiFI urządzenia (które podczas konfiguracji jest AP)
  3. ponownie łączy się z siecą wifi X

w tym czasie Ty na swoim komputerze jesteś połączony ciągle z wifi X
co oznacza, że w punkcie 2 nie masz połączenia z bramką

dlatego ten komunikat w aplikacji - pomimo, że wszsytko jest OK
gdybyś robił to na bramce (podłączonej do monitora / tv) to nie było by takiego komunikatu

Oczywiście postaramy się to jakoś poprawić, bo faktycznie nie jest to tak jasne dla użytkowników jak dla nas :wink:

Aaa… dobra, to wszystko wyjasnia jesli chodzi o komunikat bledu. To prosilbym o zaktualizowanie opisu podpinania urzadzen do bramki, coby inni sie nie stresowali :slight_smile:
Podlaczam sie pod post @Cino111, tez wolalbym aby AP byl domyslnie wlaczony po slfaszowaniu urzadzenia.

Nadal pozostaje problem tego ze nie jestem w stanie nauczyc mojej bramki Sonoff kodow RF :slight_smile: Jakis pomysl, sugestia, podpowiedz?

Moze zrobić jeden odzielny soft z AP dla urządzeń, które nie mają wyprowadzonego GPIO0? Każdy będzie wygrywał co mu pasuje.

1 polubienie

A jak dodać bramkę do AIS gdy jest on połączony z siecią nie poprzez WIFi tylko ethernet?
Za nic nie idzie jej dodać :frowning:

Hmm… jedyne wymaganie jest chyba takie aby bramka AIS + dodatkowe urzadzenie (typu bramka Sonoff) byly w tej samej sieci. WiFi czy ETH nie powinny robic roznicy

1 polubienie

Witamy na forum @piotrwl :slight_smile:

tak, to w jaki sposób połączona jest bramka nie powinno mieć znaczenia.
Jedyna różnica jest taka że trzeba podać hasło do WiFi (jak bramka połączona jest po ethernet to może nie znać hasła WiFi do kórego ma podłączyć urządzenie).

Jeżeli bramka jest połączona po ethernet to podczas dodawania nowego urządzenia (z softem AIS-Tasmota) rozłączy się na chwile z sieci ethernet i o tym powie:

Wyłączam lokalne połączenie z siecią ethernet. Włączam WiFi aby przesłać ustawienia do urządzenia.

for x in 1…5:
Łączę z urządzeniem, próba x

Ustawienia pomyślnie przesłane do urządzenia. Przywracam połączenie z siecią ethernet.

Tak to teoretycznie powinno działać. Oczywiście w tym czasie urządzenie musi być w trybie parowania (być AP w sieci) no i być odpowiednio blisko bramki, żeby mogła się połączyć do urządzenia i przesłać ustawienia.

Powinno to działać tak jak na tych filmikach:

tu wersja na samym głośniku (bez monitora):

U mnie po kliknięciu Zatwierdź podczas dodawania (bo bramka jest znajdowana) wyświetla się poniższy komunikat:
image

Pomimo, że ręcznie mam wpisane takie parametry jak na początku tego posta są podane, to dalej nic:

Aha, czyli Ty juz masz poprawny komunikat podczas dodawania a nie blad, ktory mi sie wyswietlal :slight_smile:

@admin.ai-speaker jakies pomysly czemu mamy problemy z uczeniem kodow RF ?

@badzio mam dobrze do momentu wyszukiwania bramki, ale nie dodaje jej.

widać, że nie masz softu AI-Speaker tylko jakiś inny (poznaje po kolorach)
jeżeli masz inny soft to nie wiemy jak on został skompilowany czy ma włączone automatyczne wykrywanie itd…
poczytaj
https://sviete.github.io/AIS-docs/docs/en/ais_faq_iot_ap_mode.html#docsNav

taki komunikat maja wszyscy, od poczatku, ale czasami klient (przegladarka z ktorej jesteś połączony z Asystentem domowym) wcześniej straci połączenie z bramką niż wyświetli ten komunikat.
Połączenie jest tracone bo bramka przełącza się na AP urządzenia.
Skomplikowane to ale postaramy się to poprawić