Uruchomienie ZigBee

Tak warto kupić do zestawu z bramką AIS ConbeeII. Jest wspierany od razu. Również takowy używam od dwóch lat i zero problemów.

Tak można:

Czytaj, czytaj, czytaj… oficjalne strony danych projektów:

Jak zmienić oprogramowanie podlinkował Ci @szopen

Dzięki za naprowadzenie na modyfikację. Na razie nie znalazłem odpowiedzi, czy w wersji router-a można będzie wykorzystać dodatkowo piny do obsługi i/o? (jak w tasmocie przez wifi)

PS: Dlaczego w DEV3 powiadomienia głosowe mam w j.angielskim choć mam ustawiony j.polski?

Użyj lupy

Ja znam tylko jeden projekt z takimi możliwościami
https://ptvo.info/
projekt ten polega w dużym skrócie na patchowaniu gotowych plików binarnych, wygenerowane samodzielnie w ten sposób firmware ma dość ograniczone możliwości, jeśli chcesz mieć pełną dowolność, to jest to rozwiązanie płatne
https://ptvo.info/zigbee-configurable-firmware-features/premium/
(przy wstawianiu powyższego linka mam wątpliwości natury etycznej - to rosyjski projekt, a wojna w Ukrainie nadal trwa…).
Patcher jest windowsowym exe’kiem, nie jestem w stanie stwierdzić czy jego używanie jest bezpieczne.

PS Nie chce mi się wierzyć, że centralki AIS nie dorobią się w miarę normalnej obsługi Z2M abyś mógł wykorzystać ten sprzęt jako normalny koordynator (bo moim skromnym zdaniem ten dongle to rozwiązanie lepsze niż oba sugerowane wyżej).

Powtórzę co napisał @Cezary.K - tak warto, cena jest warta tych “zero” problemów.

No i stałem się posiadaczem ConBee2 :wink:

Dopiero po drugim restarcie DEV3 configuracja ZigBee2MQTT ustabilizowała się choć pojawiła się taka przypadłość:
ConBee

Oczywiście dodałem:

adapter: deconz

Jak to ugryźć?

Po wcześniejszych próbach pozostał mi:
MQTT
Czy to mogło spowodować problem?

w ustawieniach Zigbee2Mqtt pod http://IP_DEV3/config/ais_dom_zigbee - w yaml
powinno być w sekcji serial

serial:
  adapter: deconz
  port: /dev/ttyACM0

w terminalu (http://IP_DEV3/developer-tools/console) sprawdź poleceniem:
ls -al /dev/ttyACM0
czy masz coś takiego:
crwxrwxrwx 1 root root 166, 0 Nov 9 20:21 /dev/ttyACM0

Niestety:

ls: cannot access '/dev/ttyACM0': No such file or directory

no to bramka dev3 nie widzi conbee2,
wyjmij stick’a i włóż AIS na bramce powinno gadać że podłączasz coś

To nie jest jakaś przypadłość, tylko system HA wykrył urządzenie (ConBee II) i próbue ponownie skonfigurować sprzęt z wcześniejszą integracją ZHA. Widocznie ją próbowałeś wcześniej. Odinstaluj Zigbee Home Automation, bo obie integracje ZHA i Zigbee2MQTT będą upominać się o koordynator. A Conbee nie może działać jednocześnie z dwoma.

MQTT też usunąć i ponownie zainstalować?

Jak usunąć ZHA? Nie widzę jej w Devices.

Na razie usunąłem ZigBee2MQTT i chyba wtedy usunął się też ZHA…
Co ciekawe nic jeszcze ponownie nie instalowałem/dodawałem, to przez “Konfiguracja Zigbee2MQTT” mogę oglądać i dodawać urządzenia Zigbee.
Czy sama się “doinstalowała” obsługa?

Gdzie można znaleźć ZHA w HA?

Powiem Ci, że dawno nie było tu kogoś, kto tak lekko podchodzi do tematu i nie przeczytał chyba nic z dokumentacji.
Proponuję na początek lektury:

Na deser:

@Cezary.K ponownie przeczytałem te lektury i nie znalazłem odpowiedzi.
Poza tym kupując DEV3 chciałem zmniejszyć czas na konfigurowanie jaki trzeba poświęcić na HA pod Rpi.
Jak już urzyłeś takich słów, to mam wrażenie, że wcześniej miałeś system na Rpi i dlatego musiałeś się zagłębiać w szczegółową konfiguracje.

Naprawdę niektórzy mają dużo innych zajęć i szukają zoptymalizowanych urządzeń aby szybko skonfigurować własny “system domowy”.

Wcześniej z powodu próby uruchomienia SONOFF Zigbee 3.0 USB Dongle Plus-P, mógł zrobić się bałagan z softem, dlatego pytam o rekonfiguracje bramki.

  1. kliknij trzykropki koło “KONFIGURUJ” i kliknij usuń.
  2. Odłącz Conbee2 z USB
  3. Wyłącz bramkę z prądu
  4. Włącz bramkę do pradu
  5. Podłącz Conbee2 do USB

Jak na stwierdzenie że masz doświadczenia z RPi to bardzo lakonicznie opisujesz swoje problemy.
Np.
image
Po czym dowiadujemy się że ten standardowy to jednak jakiś zakup z allegro CC2652:

Zadajesz dodatkowe pytania niezwiązane z początkowym tematem co robi śmietnik z wątku co powoduje to że robi się jeszcze bardziej nieczytelnie.

Niepisana zasada na każdym forum jest taka: czym lepiej wyjaśnisz problem i czy lepiej będziesz współpracował tym szybciej znajdziesz rozwiązanie.

1 polubienie

Nie nie miałem pojęcia o istnieniu HA dopuki nie kupiłem bramki DEV1. Nie jestem programistą czy informatykiem. Nie mam żadnego wykształcenia w tych kierunkach. Ale zawsze staram się przygotować przed zadaniem pytania na forum. I najczęściej czytając dokumentację znajduję potrzebne informacje, a dopytuję o szczegóły. Jeśli szukasz rozwiązania uniwersalnego to HA jest takim, ale nie można ignorować jego stopnia skomplikowania i możliwości osiągania tych samych funkcjonalności czy usług różnymi metodami, bez zrozumienia jak to wszystko działa.

Po połączeniu poprzez ftp z bramką w folderze zigbee2mqtt/data/ w pliku configuration.yaml wklej to zachowując odstępy.

homeassistant: true
permit_join: false
mqtt:
base_topic: zigbee2mqtt
server: mqtt://localhost
serial:
port: /dev/ttyACM0
adapter: deconz
advanced:
log_level: info
log_output:
- console
frontend:
port: 8099
channel: 11

1 polubienie

@Stravi, zauważ że napisałem o tym, że usunąłem ZigBee2MQTT i nie mogę znaleźć gdzie jest zainstalowane ZHA. Zakładam, że to dwa różne softy. Tylko gdzie on ma swoje okno konfiguracji?

Nie pisałem, że znam dobrze HA na Rpi. Malinę konfigurowaliśmy razem ze znajomym informatykiem, ale niestety już nie zrobimy tego z DEV3 (konsekwencje Covidu).

Rzeczywiście błędem było poruszenie tu tematu audio, ale myślałem że to prosta odpowiedź, dlatego użyłem “Przy okazji powiedzcie…” Dlatego utworzę nowy temat.

Opisz proszę jak to zrobiłeś.