BETA 🌱 Nowa wersja 0.109 wydana na kanale BETA

Cześć! wersja 0.109.2b1 została wydana na kanale beta

:seedling:

Pogoda nie rozpieszcza :sun_behind_rain_cloud: no i nie ma gdzie jechać w tą majówkę bo kwarantanna… więc wydajemy nową wersję :wink:

:warning: Uwaga, jeżeli po aktualizacji Zigbee i ponownym uruchomieniu systemu status Zigbee nie będzie online, to trzeba wyciągnąć i włożyć dongla usb z zigbee.

Jolka powie:

  • Usunięto urządzenie zigbee
  • Zatrzymano serwis zigbee
  • Dodano urządzenie zigbee
  • Uruchomino serwis zigbee

i wszystko będzie OK.

Zmiany:

Home Assistant w wersji 0.109.2

Zigbee2Mqtt w wersji 1.13.0 :honeybee:

jeż już 741 wspieranych urządzeń od 133 producentów :clap: :


Jest kilka fajnych zmian w aplikacji Home Assistant:

  • integracje wyglądają ładniej:

  • i komponent pogoda też jest ładniejszy:

Istotna jest też zmiana pod spodem - wykrywanie blokowania Home Assistant przez integracje.
Ma to na celu poprawę wydajności i stabilność Home Assistant.

Gdybyście zobaczyli w logach coś takiego:

To zgodnie z instrukcją z loga zgłaszajcie to w repozytorium Home Assistant lub w repozytoriach autorów niestandardowych komponentów.

Są też zmiany usprawniające pobieranie tłumaczeń w aplikacji webowej - interfejs ładuje mniej danych, a tym samym jest lżejszy dla przeglądarki :+1:

Udanej majówki :v:

1polubienie

Super, broadlink ponownie działa, moje rolety ożyły :ok_hand:, ale jest problem z zigbee ponieważ pobiera aktualizacje, instaluje, uruchamia się ponownie z wersją 1.12.2 i tak w kółko.
ps.
po piątym razie próby instalacji aktualizacji straciło mi dysk z bazą danych i po ponownym uruchomieniu bramki ponownie nie widzi urządzeń MQTT z waszym softem ustawionym zgodnie z zaleceniami trzeba je restartować :cry:

to rzeczywiście :sleepy:

Faktycznie - nowa wersja jeszcze nie była dostępna na OTA - dzieki za info.
Już powinno być OK - daj znać czy działa?

PS
Gdyby coś dalej się nie aktualizowało to wykonaj prszę takie komendy w konsoli.
To mniej więcej jest wykonywane podczas katualizacji - w ten sposób dojdziemy do tego co jest nie tak.

# zatrzymanie serwisu zigbee
pm2 stop zigbee

# przejście do folderu domowego
cd ~

# pobranie nowej wersji z ota
curl -o zigbee.zip https://powiedz.co/ota/zigbee.zip 

# kopia bieżącej konfiguracji
cp -r zigbee2mqtt/data zigbee_backup

# usuwamy starszą wersję zigbee
rm -rf zigbee2mqtt

# rozpakowujemy nowa wersje
7z x -mmt=2 -o/data/data/pl.sviete.dom/files/home/zigbee2mqtt ~/zigbee.zip -y

# przywracamy konfigurację z kopii
cp -r zigbee2mqtt/data zigbee_backup

# uruchoienie serwisu zigbee
pm2 start zigbee

Poszło od strzała bez kombinacji, poza ponownym restartem urządzeń MQTT, które zostały niedostępne. Pozdrawiam miłego weekendu życzę :wink:

dzieki za info - wzajemnie miłego! :slight_smile:

Nie wiem czy to istotne ale podczas instalacji w konsoli pojawiły się takie
błędy i ostrzeżenia:

Faktycznie, zaczął wysłać kody RF po aktualizacji bo od kilku tygodni działały tylko kody IRda.

Sprawdź jak masz ustawiony Full Topic, u mnie działa tak jak poniżej, domyśłnie soft AIS tasmota ma tak jak jest w nawiasie, ale to nie działa prawidłowo, przynajmniej u mnie.

Dziękuję nareszcie zaczęło działać :+1: . Pozdrawiam.

Aktualizacja poszła bez problemów, ale mam taką wersję interfejsu użytkownika: 20191204.6 - latest.

Takie lamerskie pytanie - jak wlaczyc kanal beta? :thinking: Przeklikalem sie przez opcje w menu, w tym najbardziej oczywiste Konfiguracja bramki AIS i nie moge znalezc.
Przeszukalem forum, nie znalazlem takiej informacji. Na stronie ai-speaker.com takze nie.

Poprzez portal integratora, moje urządzenia>edytuj :wink:

W dokumentacji jest opis “Portalu Integratora”

tam jest opcja wyboru kanału z aktualizacjami beta

trochę to ukryte, ale wiadomo tylko dla tych co naprawdę tego chcą :wink:

PS. Każdą wersję aplikacji można też zainstalować z konsoli, np żeby jednorazowo sprawdzić sobie jakąś wersję bez przełączania się na stałe na kanał beta (albo żeby wrócić do poprzedniej wersji). Wystarczy wpisać komendę

pip install ais-dom==0.109.2b1 -U

gdzie 0.109.2b1 to ostatnia beta,
tu jest lista wersji które są wydawane

Dzieki :slight_smile: Wpisanie slowa ‘beta’ w wyszukiwanie na ai-speaker.com wyswietla kilka podpowiedzi ale akurat portalu integratora nie ma na liscie. WIec faktycznie, nie jest latwo znalezc :slight_smile:

Takie spostrzezenie (off-topic) - tworzenie konta na portalu integratora jest mega proste ale… nie zostalem poproszony o zadne potwierdzenie akcji bezposrednio na urzadzeniu. Czy to oznacza, ze przy odrobinie szczescia (jesli odnajde poprawny identyfikator) moglbym dodac sobie urzadzenie innego uzytkownika?

Teoretycznie jest to możliwe, ale…
Po pierwsze- musiałbyś zdobyć czyjś unikalny identyfikator :wink:
Po drugie- ten ktoś musiałby nie mieć dodanej bramki w swoim portalu integratora (nie ma możliwości dodania jednej bramki do wielu kont)
Po trzecie- nawet, jeśli by Ci się to jakimś cudem udało (punkt 1+2) to jedyne co mógłbyś tam ‘nabroić’ to przestawić kanał na beta lub odwrotnie :wink:
Jeśli ktoś udostępnia bramkę z Internetu (ma włączony tunel), to wymagane jest logowanie, więc dochodzi jeszcze nazwa użytkownika i hasło :wink:

Podsumowując- nie zalecamy udostępniać nigdzie identyfikatora bramki, bo hakerzy nie śpią :stuck_out_tongue_winking_eye:
Oraz zalecamy używać logowania wieloskładnikowego (wtedy nawet identyfikator, nazwa użytkownika i hasło nie wystarczą, trzeba wpisać wygenerowane jednorazowe hasło, które szybko traci ważność).

Stay safe :lock: :wink:

Niestety, czasami moze sie wkleic id bramki, np podczas wrzucania screenshotow na forum. Wszyscy staraja sie pilnowac ale czasami moze sie to zdarzyc.
Zatem jednak fajnie byloby gdyby dodawanie bramki wymagalo zatwierdzenia tego w interfejsie na urzadzeniu.

pomysł w sumie dobry, więc do przemyślenia @jolka :wink:

(może trzeba będzie dodać Portal Integratora jako integrację- pomyślimy) :slight_smile:

1polubienie

Dd nowej wersji, po wykonaniu kopii zapasowej, zauważyłem taki błąd jak poniżej.


Po nazwach plików widzę przewija się zigbee, którego nie używam…

to tylko zły poziom loga, ktoś dał error a miało być debug
image

już poprawione - dzięki za info:

image

PS
Nawet jeśli nie używasz zigbee to i tak je aktualizujemy, żeby wszystkit kody były na bieżąco (całe zigbee to tylko 20 MB zip-a).
Jak będzie taka potrzeba to możemy to aktualizowanie zigbee wyłączyć (ustawiając wersję na 0) ale może zostawmy to jeszcze na razie tak.

Cześć @fenixjac witamy na forum :v:

to pewnie dlatego, że interfejs się jeszcze nie “odświeżył” w przeglądarce.

Żeby apka webowa działała płynnie, robimy coś takiego jak agresywne buforowanie (aggressive caching) wszystkie kody apki są zapisywane w przeglądarce. Po jakimś czasie pojawi się opcja odświeżenia interfejsu (jak przeglądarka pobierze nowy - staramy się tą opcję wyświetlać jak najszybciej po aktulizacji).
Albo można nie czekać i pomóc przeglądarce odświeżyć apke:

image