馃 Leon wydanie na PROD

Tylko pami臋taj, ze 11 kana艂 Zigbee to nie to samo co 11 kana艂 WiFi

1 polubienie

Co to znaczy bo tak bieg艂y nie jestem. A jak ju偶 to czy wchodzi w rachub臋 zmiana kana艂u Zigbee, je偶eli tak to na jaki

W艂a艣nie o to mi chodzi艂o o restart HA AIS
Dodam, 偶e posiadam conbee II i routery gniazdka blitzwolf i z zasi臋giem nie ma 偶adnego problemu, problem jest g艂贸wnie z czujnikami ruchu i otwarcia aqara

Na poni偶szym obrazku wida膰 jak rozk艂ada si臋 wykorzystanie pasma 2,4GHz przez r贸偶ne protoko艂y.
11 kana艂 Zigbee (ten na samym dole) pokrywa si臋 z kawa艂kiem kana艂u 1 WiFi. O ile u siebie mo偶esz ustawi膰 tak WiFi, 偶eby nie u偶ywa艂 kana艂u 1 tylko 2 i Twoje WiFi nie b臋dzie zak艂贸ca艂o Zigbee, ale WiFi s膮siad贸w lub publiczne mo偶e u偶ywa膰 kana艂 1. Z tego co zauwa偶am, najcz臋艣ciej WiFi domy艣lnie u偶ywa swoich kana艂贸w 1, 6 i 11, a to oznacza, 偶e najlepsze warunki dla Zigbee s膮 na jego kana艂ach 15, 20, 25 i 26.

3 polubienia

Dzi臋ki, super obja艣nienie, co艣 b臋d臋 pr贸bowa艂 zrobi膰

Witam. Nie mia艂 ch艂op k艂opot贸w kupi艂 DEV3, czy kto艣 ma problem z zapisem historii na dysku usb lub na karcie ? Bo mi tworzy plik ais.db wielko艣膰 0 i na tym koniec, na DEV2 na LEONIE to chodzi艂o ! I jeszcze jedna sprawa na DEV2 mia艂em obs艂ug臋 formatu EXT4 a na DEV3 tylko fat, nie pami臋tam czy co艣 instalowa艂em m贸g艂 by kto艣 naprowadzi膰 jak zmusi膰 DEV3 do obs艂ugi EXT4.

Je偶eli komu艣 nie dzia艂a zigbee to tu opisa艂em jak zdiagnozowa膰 problem:

4 polubienia

Po aktualizacji wywali艂o mi TUYA brak urz膮dze艅, i zigbbe . Temat powy偶ej nie pomaga brak wykrytego urz膮dzenia . Nadajnik od pilota wykrywa conbee ju偶 nie, jak zmieni臋 na stary CC2531 to wykryje urz膮dzenie , ale ma problem uruchomi膰 zigbee. Masakra , a ju偶 by艂o w miar臋 stabilnie. Kolejny problem nie zwi膮zany z aktualizacj膮 to zanik w sieni po restarcie routera, niby nadany sta艂y IP ale po restarcie routera i tak musz臋 restartowa膰 bramk臋. Jest mo偶liwo艣膰 przypisa膰 IP tak偶e w bramce dla po艂膮czenia LAN ?
Edit : Integracja Satela te偶 wywalona super.

Tak - robisz to w ustawieniach Androida na bramce. Zak艂adka sie膰 zmieniasz na statyczny IP.

Po kilku restartach i sprawdzeniu konfiguracji integracja satela wr贸ci艂a. ZIgbee nowa integracja ZIGBEE HOME AUTOMATION wykry艂o conbee , ale nie po艂膮czy艂 z istniej膮cymi odbiornikami, kt贸re s膮 widoczne w MQTT . ZIGBEE2MQTT ca艂y czas si臋 kr臋ci nie pomaga restart z konsoli. Zrobi艂em r臋czne parowanie jednego czujnika do nowej integracji i wykry艂o jeden z czujnik贸w. Chyba czeka mnie ponowne 艂膮czenie odbiornik贸w do nowej integracji masakra mam ich do艣膰 du偶o. Nadal nie rozgryz艂em TUYA nie mog臋 si臋 zalogowa膰 na swoje konto przez AIS z telefonu idzie bez problemu za pomoc膮 apki TUYA.

ZHA (Zigbee Home Automation) to odpowiednik Zigbee2MQTT (Z2M), to s膮 dwa r贸偶ne rozwi膮zania do obs艂ugi Zigbee (dwie r贸偶ne integracje), czujniki sparowane w Z2M nie pojawi膮 si臋 w ZHA, cud贸w nie b臋dzie - dany czujnik mo偶e by膰 tylko w jednej integracji.

ZHA i Z2M wymagaj膮 koordynatora sieci Zigbee, je偶eli 鈥減od艂膮czysz鈥 Conbee do ZHA, nie mo偶esz go wykorzysta膰 jednocze艣nie w Z2M - jednocze艣nie jeden stick/dongle mo偶e by膰 w jednej integracji. Nie b臋d臋 opisywa艂 mo偶liwych 鈥渒ombinacji鈥 偶eby nie namiesza膰 Ci w g艂owie.

Rozumiem , tyle 偶e bramka nie wykrywa艂a z automatu jak to by艂o przed aktualizacj膮 CONBE wykry艂a tylko cc2531 a i tak integracja si臋 nie uruchamia艂a. CONBEE nie chcia艂a wykry膰. Dla sprawdzenia zrobi艂em integracj臋 ZIGBEE HOME AUTOMATION i tam urz膮dzenie wykryte i parowanie dzia艂a. Natomiast Z2M dalej si臋 kr臋ci.

Odpowiem standardowo:
pm2 restart zigbee & pm2 logs zigbee

Niestety restart oraz funkcja stop i start nic nie zmienia . Nadal jest Error: Cannot find module 鈥榶allist鈥. Po usuni臋ciu integracji ZIGBEE HOME AUTOMATION , modu艂 conbee nie jest wykryty przez bramk臋 . Przedtem z automatu by艂a informacj膮 ze po艂膮czono modu艂 itp. Pod艂膮czaj膮c modu艂 od pilota jest ok .

pm2 restart zigbee & pm2 logs zigbee

Tu nie chodzi o sam restart dla restartu. Chodzi o zebranie log贸w dla zdiagnozowania problemu. Bez tego mo偶esz powtarza膰 czynno艣ci, kt贸re nic nie wnosz膮. Mo偶e lepiej si臋 poczujesz jak si臋 wy偶alisz na forum ale nie ma jak Ci pom贸c.

@scorpik77 sprawd藕 czy w zigbee2mqtt/data/configuration.yaml masz wpisany dobry dongiel, powinno by膰 co艣 takiego

serial:
  port: /dev/ttyACM0
  adapter: deconz

z czego wa偶ny jest deconz

Racja zapomnia艂em o logach przepraszam :

[TAILING] Tailing last 15 lines for [zigbee] process (change the value with --lines option)
10|zigbee | Error: Cannot find module 鈥榶allist鈥
10|zigbee | Require stack:
10|zigbee | - /data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/lru-cache/index.js
10|zigbee | - /data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/semver/classes/range.js
10|zigbee | - /data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/semver/classes/comparator.js
10|zigbee | - /data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/semver/index.js
10|zigbee | - /data/data/pl.sviete.dom/files/home/zigbee2mqtt/index.js
10|zigbee | at Function.Module._resolveFilename (internal/modules/cjs/loader.js:889:15)
10|zigbee | at Module.Hook._require.Module.require (/data/data/pl.sviete.dom/files/usr/lib/node_modules/pm2/node_modules/require-in-the-middle/index.js:61:29)
10|zigbee | at require (internal/modules/cjs/helpers.js:92:18)
10|zigbee | at Object. (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/lru-cache/index.js:4:17)
10|zigbee | at Module._compile (internal/modules/cjs/loader.js:1072:14)
10|zigbee | at Object.Module._extensions鈥s (internal/modules/cjs/loader.js:1101:10)
10|zigbee | at Module.load (internal/modules/cjs/loader.js:937:32)
10|zigbee | at Function.Module._load (internal/modules/cjs/loader.js:778:12)
10|zigbee | at Module.require (internal/modules/cjs/loader.js:961:19)
10|zigbee | at Module.Hook._require.Module.require (/data/data/pl.sviete.dom/files/usr/lib/node_modules/pm2/node_modules/require-in-the-middle/index.js:80:39) {
10|zigbee | code: 鈥楳ODULE_NOT_FOUND鈥,
10|zigbee | requireStack: [
10|zigbee | 鈥/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/lru-cache/index.js鈥,
10|zigbee | 鈥/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/semver/classes/range.js鈥,
10|zigbee | 鈥/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/semver/classes/comparator.js鈥,
10|zigbee | 鈥/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/semver/index.js鈥,
10|zigbee | 鈥/data/data/pl.sviete.dom/files/home/zigbee2mqtt/index.js鈥
10|zigbee | ]
10|zigbee | }

do tego wpis w config :

homeassistant: true
permit_join: false
mqtt:
base_topic: zigbee2mqtt
server: 鈥榤qtt://localhost鈥
serial:
port: /dev/ttyACM0
adapter: deconz
frontend:
port: 8099
advanced:
log_level: info
log_output:
- console
channel: 11

EDIT: ZIGBEE naprawione , ca艂o艣膰 aktualizowa艂em z konsoli na piechot臋. Nast臋pnie przywr贸cenie kopi z backupu. Teraz poprawiam encje kt贸re zmieni艂em ze switch na light, cz臋艣膰 jest zdublowana i ma nie przypisane encje ( zmieni艂y si臋 nazwy ) , podobny ba艂agan na froniusie integracja kt贸rej nie by艂o w poprzedniej wersji i robi艂em przez wpis do configuracji nagle si臋 pojawi艂a. Zosta艂 jeszcze TUYA :frowning: do odratowania.

Uda艂o mi si臋 w ko艅cu podnie艣膰 wersj臋 Z2M, przej艣膰 na starsz膮 oraz wr贸ci膰 i ju偶 niestety za ka偶dym razem dostaj臋 b艂膮d SRSP - SYS. Czy dobrze zak艂adam, 偶e pozostaje mi przej艣cie na Conbee 2 czy co艣 jeszcze mo偶ecie poleci膰? Przed aktualizacj膮 to CC2531 oczywi艣cie dzia艂a艂o鈥

10|zigbee  | Zigbee2MQTT:error 2022-01-19 00:41:30: Error while starting zigbee-herdsman
10|zigbee  | Zigbee2MQTT:error 2022-01-19 00:41:30: Failed to start zigbee
10|zigbee  | Zigbee2MQTT:error 2022-01-19 00:41:30: Check https://www.zigbee2mqtt.io/guide/installation/20_zigbee2mqtt-fails-to-start.html for possible solutions
10|zigbee  | Zigbee2MQTT:error 2022-01-19 00:41:30: Exiting...
10|zigbee  | Zigbee2MQTT:error 2022-01-19 00:41:30: Error: Failed to connect to the adapter (Error: SRSP - SYS - ping after 6000ms)
10|zigbee  |     at ZStackAdapter.start (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/zigbee-herdsman/src/adapter/z-stack/adapter/zStackAdapter.ts:102:27)
10|zigbee  |     at Controller.start (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/node_modules/zigbee-herdsman/src/controller/controller.ts:123:29)
10|zigbee  |     at Zigbee.start (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/zigbee.ts:58:27)
10|zigbee  |     at Controller.start (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/lib/controller.ts:100:27)
10|zigbee  |     at start (/data/data/pl.sviete.dom/files/home/zigbee2mqtt/index.js:97:5)

Par臋 pozytywnych informacji dotycz膮cych aktualnego Leona to stabilniejsza obs艂uga zaworu PSBZS A1 z Lidla i uaktywniony czujnik temperatury w Broadlink RM2 Pro.

Zaw贸r

Upora艂em si臋 z integracj膮 TUYA . Obecnie jak ju偶 pewnie wiadomo sam wpis w confguracji typu login i has艂o to za ma艂o . Znalaz艂em taki oto film i dzia艂a ca艂a integracja z pe艂nymi funkcjami.

1 polubienie

Poczytaj Zigbee2mqtt cc2531 - przesta艂o dzia艂a膰 - #88 przez araczkowski