🐝 Maja wydania


Kolejna wersja dostępna na kanale Alfa.

ja tu tylko puszczam skrypcik i weryfikuję czy się instaluje tak jak i inni użytkownicy kanału Alfa.
Także uważam że to niefortunne zestawienie z @araczkowski. :slight_smile:

2 polubienia

Znów bramka nie wstała po aktualizacji

Gdzie znaleźć aktualne logi z pm2 na bramce ? Bo w >dokumentacji pm2< jest że można znaleźć w tej lokalizacji

image

niby są na bramce ale sa tylko logi błędów z tunela a nie z całości wykonania pm2 log

Wnioskuję o bana (read only na forum) dla kolegi @Akszyn na 7 dni.
Zanim wróci to może przeczyta odpowiedzi udzielone na wszystkie swoje pytania i zacznie to realizować.

1 polubienie

Zakladam, że chodzi sterownik Eaton easyE4 (programowslny przekaźnik, “mini” PLC - Sterowniki easyE4 | Eaton), tylko dlaczego piszecie własną integrację skoro ten sterownik obsługuje Modbus TCP, który natywnie wspiera HA. Jaka jest wg Was przewaga integracji po http:
JSON API Web Servera easyE4 może być używany do komunikacji poprzez zapytania HTTP-GET. Oznacza to, że do znaczników, ustawień i danych sterownika Eaton easy można uzyskać dostęp w trybie zapisu i odczytu w różnych środowiskach programowania.

BTW easyE4 to fajny, uniwersalny sterownik ale jak juz pisałem poległem na programowaniu funkcjonalnosci multi-press :frowning:.

3 polubienia

tak - tym się teraz bawimy :slight_smile:

ta integracja modbus nie działa nam dobrze, a ta web server / http działa dobrze :wink:
jeszcze się tym pobawimy (pewnie kilka miesięcy) i zobaczymy, w którą stronę to pójdzie
Tobie działa integracja z Easy4 via modbus? Jak tak to opisz proszę, w osobnym temacie jak się komunikujesz z tym PLC z HA - z przykładem konfiguracji modbus w yaml, może my coś żle robimy…

My programujemy sterownik w języku strukturalny ST, multi press chyba nie powinien być problemem przy użyciu znaczników… chyba (jeszcze tego nie robiliśmy, narazie mamy działające przełączniki i teraz podłączamy czujniki)

Wszystko co do tej pory robilem na tym sterowniku to tylko symulacja w programie, z uwagi na niepowodzenie w programowaniu akcji multi-press w ST nie zecydowalem sie na zakup tego sterownika PLC, może kiedyś (teraz musialem szybko na cos sie zdecydować wiec Sterowniki Kincony) wszystko pod ten sterownik jest przygotowane w rozdzielnicy (remont mieszkania w trakcie …).

Osobiście uważam, ze współpraca AIS z dobrym automatykiem, który ogarnie programowanie tego easyE4 może być fajnym pomysłem na sterownik do AI-Speaker. Z wgraniem programu i skonfigurowaniem easyE4 poradzi sobie każdy kto radzi sobie z Waszą bramką.

Zrob nowy temat, podaj konfigurację Modbus TCP a napewno pomogę, na innyn forum pomagałem w tym temacie niejednokrotnie. Modbus jest prosty (mam urzadzenia Mobus RTU, na razie na RPi zrobilem sobie bramke Modbus TCP), dokumentację do easyE4 mam, HA znam, rozwiazywanie problemów i wyzwania lubię :slight_smile:.

6 polubień

Maja wydana na kanale Alfa i Beta

image

To pierwsze wydanie na beta w tym roku. Wydanie zawiera pierwszą stabilną wersję Home Assistant wydaną w tym roku → 2022.2.9
Do końca tygodnia wydamy na kanale Alfa, AIS HA 2022.3.0.
Za miesiąć wydamy na Beta 2022.3.x

W razie problemów z aktualizacją, dajcie znać co jest w logach podczas installacji z konsoli:

4 polubienia

Ślicznie dziękuję za Maję Beta! Nareszcie ruszyły wszystkie moje urządzenia ZigBee, które dotychczas nie były obsługiwane :slight_smile:

Aktualizacja na DEV3 trwała 6 minut i przebiegła bez najmniejszych problemów, ale w Konfiguracji zniknęła zakładka Energia (przepraszam, jeżeli wyrażam się niefachowo). Mogę ją znaleźć przez lupkę, i działa prawidłowo, a jedynie dostęp do niej stał się nieco utrudniony.

Dzięki jeszcze raz!

2 polubienia

Takie off top. Hurrrra @jolka wróciła

5 polubień

Konfiguracja - Pulpity Nawigacyjne

2 polubienia

Dzięki. Udało mi się ją tam zlokalizować. W sumie to dobre miejsce dla niej i nie będę próbował go zmieniać :slight_smile:

Maja ma ten sam problem co poprzednik . Mianowicie po starcie bramki przed routerem - bramka podpięta pod lan, Ais nie pobiera sobie adresu lub zawiesza się. (Bramka uzyskuje poprawny adres) do Ais można się dostać po ssh

:wave: Hej

Maja na kanale PRE ALFA, kolejne wydanie

Najnowszy HA w wersji 2022.3.0b2 który zostanie wydany za tydzień, a w nim:

Ulepszenia w bibliotece mediów- łatwe dodawanie i usuwanie mediów na bramce:

Nowa akcja “play media” dostępna w automatyzacji z wygodnym wybieraniem pozycji z biblioteki do odtwarzania

Nowa biblioteka stacji radiowych

na ALFA aktualizaja będzie dostępna po wydaniu i instalacji przez @Stravi

2 polubienia


Zapraszam!

1 polubienie

tak u mnie przebiegł proces aktualizacji z konsoli (znów błąd restartu)

Ta konsola ma moce Super Krowy.            
~ $ curl -L https://raw.githubusercontent.com/sviete/AIS-utils/master/releases/alfa.sh -o alfa.sh
chmod +x alfa.sh
./alfa.sh
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  8057  100  8057    0     0  22087      0 --:--:-- --:--:-- --:--:-- 22134
 START instalacji wersji  AIS ALFA  22.02.17 
Ign:1 https://powiedz.co/apt dom InRelease
Ign:2 https://powiedz.co/apt python InRelease
Hit:3 https://powiedz.co/apt dom Release
Hit:4 https://powiedz.co/apt python Release
Ign:5 https://powiedz.co/apt dom Release.gpg
Ign:6 https://powiedz.co/apt python Release.gpg
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
45 packages can be upgraded. Run 'apt list --upgradable' to see them.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   756  100   756    0     0   2374      0 --:--:-- --:--:-- --:--:--  2369
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
w3m is already the newest version (0.5.3.20190105-6).
0 upgraded, 0 newly installed, 0 to remove and 45 not upgraded.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
neofetch is already the newest version (7.1.0).
0 upgraded, 0 newly installed, 0 to remove and 45 not upgraded.
         ⣴⣿⣿⣆                      u0_a62@localhost 
        ⣿⣿⣿⣿⣿⣿                     ---------------- 
        ⣿⣿⣿⣿⣿⣿                     OS: Android 7.1.2 armv8l 
        ⣿⣿⣿⣿⣿⣿    ⣴⣿⣿⣆             Host: Amlogic AI-Speaker.com 
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿            Kernel: 3.14.29 
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿    ⣴⣿⣿⣆    Uptime: 4 days, 14 hours, 56 mins 
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   Packages: 173 (dpkg), 1 (pkg) 
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   Shell: bash 5.1.8 
                                   Terminal: /dev/pts/1 
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   CPU: Amlogic (4) @ 1.200GHz 
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿   Memory: 501MiB / 959MiB 
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿    ⠻⣿⣿⠏
        ⣿⣿⣿⣿⣿⣿   ⣿⣿⣿⣿⣿⣿                                    
        ⣿⣿⣿⣿⣿⣿    ⠻⣿⣿⠏                                     
        ⣿⣿⣿⣿⣿⣿
        ⣿⣿⣿⣿⣿⣿
         ⠻⣿⣿⠏

 Aktualizacja AIS z wersji  22.02.15  
 VERSION TEST  OK 
 FIX for error on HA start... 
rm: cannot remove '/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/components/config/group.py': No such file or directory
 Pobieram AIS ... 
ok  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   144  100   144    0     0    369      0 --:--:-- --:--:-- --:--:--   369
100   155  100   155    0     0    277      0 --:--:-- --:--:-- --:--:--   277
100 56.5M  100 56.5M    0     0  5960k      0  0:00:09  0:00:09 --:--:-- 7204k
 Rozpakowuje AIS ... 
ok
7-Zip [32] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=utf8,Utf16=on,HugeFiles=off,32 bits,4 CPUs LE)

Scanning the drive for archives:
1 file, 59289313 bytes (57 MiB)                   

Extracting archive: /data/data/pl.sviete.dom/files/home/AIS/alfa_wheelhouse.tar.7z
--
Path = /data/data/pl.sviete.dom/files/home/AIS/alfa_wheelhouse.tar.7z
Type = 7z
Physical Size = 59289313
Headers Size = 1432
Method = LZMA2:24
Solid = +
Blocks = 1

Everything is Ok                                            

Folders: 1
Files: 57
Size:       65593502
Compressed: 59289313
 Instaluje AIS ... 
okLooking in links: wheels
Requirement already up-to-date: aiohttp==3.8.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 3)) (3.8.1)
Requirement already up-to-date: astral==2.2 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 4)) (2.2)
Requirement already up-to-date: async_timeout==4.0.2 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 5)) (4.0.2)
Requirement already up-to-date: attrs==21.2.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 6)) (21.2.0)
Requirement already up-to-date: atomicwrites==1.4.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 7)) (1.4.0)
Processing ./wheels/awesomeversion-22.2.0-py3-none-any.whl
Requirement already up-to-date: bcrypt==3.1.7 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 9)) (3.1.7)
Requirement already up-to-date: certifi>=2021.5.30 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 10)) (2021.10.8)
Requirement already up-to-date: ciso8601==2.2.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 11)) (2.2.0)
Requirement already up-to-date: httpx==0.21.3 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 12)) (0.21.3)
Requirement already up-to-date: ifaddr==0.1.7 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 13)) (0.1.7)
Requirement already up-to-date: jinja2==3.0.3 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 14)) (3.0.3)
Requirement already up-to-date: PyJWT==2.1.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 15)) (2.1.0)
Requirement already up-to-date: cryptography==35.0.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 16)) (35.0.0)
Processing ./wheels/pip-22.0.3-py3-none-any.whl
Requirement already up-to-date: python-slugify==4.0.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 18)) (4.0.1)
Requirement already up-to-date: pyyaml==6.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 19)) (6.0)
Requirement already up-to-date: requests==2.27.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 20)) (2.27.1)
Requirement already up-to-date: typing-extensions<5.0,>=3.10.0.2 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 21)) (4.1.1)
Requirement already up-to-date: voluptuous==0.12.2 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 22)) (0.12.2)
Requirement already up-to-date: voluptuous-serialize==2.5.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 23)) (2.5.0)
Requirement already up-to-date: yarl==1.7.2 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 24)) (1.7.2)
Processing ./wheels/ais_dom_frontend-20220224.0-py3-none-any.whl
Requirement already up-to-date: aisapi==0.1.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 27)) (0.1.1)
Requirement already up-to-date: tzdata in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from -r wheels/requirements.txt (line 28)) (2021.5)
Processing ./wheels/ais_dom-2022.3.0b2-py3-none-any.whl
Requirement already satisfied, skipping upgrade: multidict<7.0,>=4.5 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from aiohttp==3.8.1->-r wheels/requirements.txt (line 3)) (4.7.6)
Requirement already satisfied, skipping upgrade: frozenlist>=1.1.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from aiohttp==3.8.1->-r wheels/requirements.txt (line 3)) (1.2.0)
Requirement already satisfied, skipping upgrade: charset-normalizer<3.0,>=2.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from aiohttp==3.8.1->-r wheels/requirements.txt (line 3)) (2.0.4)
Requirement already satisfied, skipping upgrade: aiosignal>=1.1.2 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from aiohttp==3.8.1->-r wheels/requirements.txt (line 3)) (1.2.0)
Requirement already satisfied, skipping upgrade: pytz in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from astral==2.2->-r wheels/requirements.txt (line 4)) (2021.1)
Requirement already satisfied, skipping upgrade: cffi>=1.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from bcrypt==3.1.7->-r wheels/requirements.txt (line 9)) (1.14.6)
Requirement already satisfied, skipping upgrade: six>=1.4.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from bcrypt==3.1.7->-r wheels/requirements.txt (line 9)) (1.15.0)
Requirement already satisfied, skipping upgrade: rfc3986[idna2008]<2,>=1.3 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from httpx==0.21.3->-r wheels/requirements.txt (line 12)) (1.4.0)
Requirement already satisfied, skipping upgrade: httpcore<0.15.0,>=0.14.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from httpx==0.21.3->-r wheels/requirements.txt (line 12)) (0.14.3)
Requirement already satisfied, skipping upgrade: sniffio in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from httpx==0.21.3->-r wheels/requirements.txt (line 12)) (1.2.0)
Requirement already satisfied, skipping upgrade: MarkupSafe>=2.0 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from jinja2==3.0.3->-r wheels/requirements.txt (line 14)) (2.0.1)
Requirement already satisfied, skipping upgrade: text-unidecode>=1.3 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from python-slugify==4.0.1->-r wheels/requirements.txt (line 18)) (1.3)
Requirement already satisfied, skipping upgrade: urllib3<1.27,>=1.21.1 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from requests==2.27.1->-r wheels/requirements.txt (line 20)) (1.26.5)
Requirement already satisfied, skipping upgrade: idna<4,>=2.5; python_version >= "3" in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from requests==2.27.1->-r wheels/requirements.txt (line 20)) (2.10)
Requirement already satisfied, skipping upgrade: pycparser in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from cffi>=1.1->bcrypt==3.1.7->-r wheels/requirements.txt (line 9)) (2.20)
Requirement already satisfied, skipping upgrade: h11<0.13,>=0.11 in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from httpcore<0.15.0,>=0.14.0->httpx==0.21.3->-r wheels/requirements.txt (line 12)) (0.11.0)
Requirement already satisfied, skipping upgrade: anyio==3.* in /data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages (from httpcore<0.15.0,>=0.14.0->httpx==0.21.3->-r wheels/requirements.txt (line 12)) (3.4.0)
Installing collected packages: awesomeversion, pip, ais-dom-frontend, ais-dom
  Attempting uninstall: awesomeversion
    Found existing installation: awesomeversion 22.1.0
    Uninstalling awesomeversion-22.1.0:
      Successfully uninstalled awesomeversion-22.1.0
  Attempting uninstall: pip
    Found existing installation: pip 20.2.4
    Uninstalling pip-20.2.4:
      Successfully uninstalled pip-20.2.4
  Attempting uninstall: ais-dom-frontend
    Found existing installation: ais-dom-frontend 20220203.0
    Uninstalling ais-dom-frontend-20220203.0:
      Successfully uninstalled ais-dom-frontend-20220203.0
  Attempting uninstall: ais-dom
    Found existing installation: ais-dom 2022.2.8b0
    Uninstalling ais-dom-2022.2.8b0:
      Successfully uninstalled ais-dom-2022.2.8b0
Successfully installed ais-dom-2022.3.0b2 ais-dom-frontend-20220224.0 awesomeversion-22.2.0 pip-22.0.3
 ZIGBEE   "version": "1.23.0", 
 Zigbee OK... 
 OK. Instalacja trwała  299 sekund 
ok ANDROID SCREEN APP  
ok Pobieram i instaluje Android Screen APK... 
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   142  100   142    0     0    342      0 --:--:-- --:--:-- --:--:--   342
100   153  100   153    0     0    171      0 --:--:-- --:--:-- --:--:--   171
100 3356k  100 3356k    0     0  2026k      0  0:00:01  0:00:01 --:--:-- 9927k
Success
 ANDROID   versionName=3.0.1 
 Android OK... 
 Restartuje usługę ais ... 
okUse --update-env to update environment variables
[PM2] Applying action restartProcessId on app [ais](ids: [ 2 ])
[PM2][ERROR] Process 2 not found
~

a po ręcznym restarcie z konsoli mam takie błędy w logach

Logger: homeassistant
Source: components/dhcp/__init__.py:285
First occurred: 04:11:39 (7 occurrences)
Last logged: 10:11:39

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/components/dhcp/__init__.py", line 285, in async_discover
    for host in await self._discover_hosts.async_discover():
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/aiodiscover/discovery.py", line 143, in async_discover
    sys_network_data = await loop.run_in_executor(None, self._get_sys_network_data)
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/concurrent/futures/thread.py", line 52, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/aiodiscover/discovery.py", line 137, in _get_sys_network_data
    sys_network_data.setup()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/aiodiscover/network.py", line 142, in setup
    resolvers = load_resolv_conf()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/aiodiscover/network.py", line 39, in load_resolv_conf
    with open("/etc/resolv.conf") as file:
FileNotFoundError: [Errno 2] No such file or directory: '/etc/resolv.conf'
Logger: homeassistant.components.sensor
Source: components/ais_mqtt_bridge/sensor.py:83
Integration: Sensor (documentation, issues)
First occurred: 03:11:27 (2 occurrences)
Last logged: 03:11:28

Error adding entities for domain sensor with platform ais_mqtt_bridge
Error while setting up ais_mqtt_bridge platform for sensor
Traceback (most recent call last):
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/helpers/entity_platform.py", line 382, in async_add_entities
    await asyncio.gather(*tasks)
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/helpers/entity_platform.py", line 614, in _async_add_entity
    await entity.add_to_platform_finish()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/helpers/entity.py", line 782, in add_to_platform_finish
    await self.async_added_to_hass()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/components/ais_mqtt_bridge/sensor.py", line 78, in async_added_to_hass
    await self._subscribe_topics()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/components/ais_mqtt_bridge/sensor.py", line 83, in _subscribe_topics
    self._sub_state = await hass_mqtt.subscription.async_subscribe_topics(
TypeError: async_subscribe_topics() takes 2 positional arguments but 3 were given
Logger: homeassistant.components.sensor
Source: components/ais_supla_mqtt/sensor.py:54
Integration: Sensor (documentation, issues)
First occurred: 03:11:27 (2 occurrences)
Last logged: 03:11:27

Error adding entities for domain sensor with platform ais_supla_mqtt
Error while setting up ais_supla_mqtt platform for sensor
Traceback (most recent call last):
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/helpers/entity_platform.py", line 382, in async_add_entities
    await asyncio.gather(*tasks)
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/helpers/entity_platform.py", line 614, in _async_add_entity
    await entity.add_to_platform_finish()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/helpers/entity.py", line 782, in add_to_platform_finish
    await self.async_added_to_hass()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/components/ais_supla_mqtt/sensor.py", line 49, in async_added_to_hass
    await self._subscribe_topics()
  File "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/homeassistant/components/ais_supla_mqtt/sensor.py", line 54, in _subscribe_topics
    self._sub_state = await hass_mqtt.subscription.async_subscribe_topics(
TypeError: async_subscribe_topics() takes 2 positional arguments but 3 were given

zaś próba dodania tej nowej integracji

kończy się niepowodzeniem

Logger: homeassistant.config_entries
Source: config_entries.py:745
First occurred: 26 lutego 2022, 03:12:47 (7 occurrences)
Last logged: 26 lutego 2022, 18:41:27

Error occurred loading configuration flow for integration radio_browser: dlopen failed: cannot locate symbol "getservbyport_r" referenced by "/data/data/pl.sviete.dom/files/usr/lib/python3.9/site-packages/pycares/_cares.cpython-39.so"...

a taki zaś jest komunikat przy próbie jej dodania
image

1 polubienie

Kolejne wydanie na PRE-ALFA, na ALFA będzie dostępne po infromacji od @Stravi

Najnowszy Home Assistant:

Home Assistant w tym wydaniu dodał sporo zmian w obszarze mediów. Można w łatwy sposób dodawać i usuwać zdjęcia do folderu galeria oraz pliki audio do folderu dyski.

zdjęcia z galerii można wyświetlać na karcie → /local/img/kuchnia.png

audio można teraz w łatwy sposób odtwarzać w automatyzacji

w automatyzacji jest nowa akcja → “Play media”

w której w łatwy sposób można wybrać plik audio do odtworzenia na głośniku podłączonym do bramki:

w analogiczny sposób można teraz łatwo z automatyzacji włączyć starcje radiową

Najnowsze Zigbee2Mqtt:

1 polubienie

Tak, radia z HA nie będą działać, bo ta integracja działa w sposób niedostępny na Android - zostajemy przy swoich stacjach radiowych.

1 polubienie

Trochę wypadłem w zeszłym tygodniu z życia.
Zapraszam do testowania.
Jest trochę logów z ostrzeżeniami o niewspieranych funkcjonalnościach, więc malkontentom polecam się wstrzymać z aktualizacją na tym etapie.

To w tej wersji nie działa Shelly?

U mnie działa, ale mam tylko 1 switch 1relay, robiłem aktualizacje skryptów od bieniu. Nie wiem czy akurat z tej integracji korzystasz.